Fastpath not working on Mac OS X

[SPARK-1696] Fastpath not working on Mac OS X - Jive Software Open Source

Fastpath is not working in Spark (probably since 2.6.0 version). The tab appears and one can see as being logged into a workgroup, but no other GUI appears in the tab (queues, agents, etc.). All other functionality is not working also (probably).

2.6.0 download 6_0.dmg

To test if Fastpath was still working on 2.6.0 on Mac.

I think i found the issue, but I’m unsure how to fix it.

The users \application support\spark for doesn’t appear to be getting updated or copied. mainly the plugin and emoticon folders. Please try this. Delete users applicaiton support\spark folder and restart spark. Now, copy over the plugins from spark application package (right click, show package contents, go to \contents\resources\plugins.) into the \applicaiton support\spark\plugins. you may have to restart spark.

Once I did this, fastpath started to work as expected.

Well, before 2.6.0 Spark was saving user’s profile in a different place. Say on Windows it was putting it directly into C:\Users\username\Spark which was incorrect and was fixed in later version to use C:\Users\username\appdata\Spark. Maybe it also affected other platforms. Though as i said, it works on Linux and i use just a tar.gz extracted version in my Home\Downloads folder.

i downloaded Spark 2.6.0 but it’s giving error this version isn’t working :s

Screen Shot 2016-02-15 at 12.47.13 PM.png

I am Using

Screen Shot 2016-02-15 at 12.52.19 PM.png

I tried this Process but it doesn’t work for me…

\contents\resources\plugins.) into the \applicaiton support\spark\plugins.

So, it looks like 2.5.8 was the only version with working Fastpath (at least for you, as it seems it works for speedy with a workaround).

Fastpath was working for me in old versions but in this one it doesn’t show pop up … even when you Log Out in Fastpath it disables the Join Button there.

Here is The Second Screen shot

You can see Join Button is not working but if il use the spark on PC instead of MAC it will work fine.

Odd…It’s working for me, although I’m not using fastpath, so my test is very limited.

speedy, you can add workgroup_name@workgroup.server to one of the shared groups (it will show error, but it will work), so it would appear in the group for other clients. Once you login to Fastpath in your Spark, such contact will appear as online to others. In another client send a message to that contact and it will send you a few questions. Then it should launch a queue in the Spark with Fastpath.

yep…that worked as a means to test it, and it appeared to work as it should. so I’m thinking Umair might be using an old plugin, and didn’t purge his plugin folder per the workaround instructions.

@Umair Mukhtar

can u send me this 2.7.5 Build 393 as i am using

Screen Shot 2016-02-18 at 11.11.22 AM.png

Probably it work fine there

The process you explained i did it as u can see here

Screen Shot 2016-02-18 at 11.12.32 AM.png

But still its like this for me

Actually it is already 397,but i don’t think it is much different from what you use. /spark_2_7_5_397.dmg

yeh i just tried it … Still the same issue with Fastpath

and you are DELETING the plugin folder in ~/Library/Application Support/Spark/plugins. and copying the one from

I am copying Plugins from Spark Package Contents / Contents / Resources / Plugins

And I am pasting it to Applications/Spark Contents/Plugins/

Screen Shot 2016-02-20 at 9.33.55 AM.png

from the above screen shot, you’re not copying it to the correct place. as I said before, it should be copied to Users/username/Library/Application Support/Spark/plugins

i cannot find this Library folder inside username can u plz check and tell me how exactly r u going into tht folder?

When i goto Macintosh HD there is this Library Folder there but when i click on it and then Application Support i cannot find Spark folder there please check the image below.

Umair, try this build /spark_2_7_5_398.dmg

speedy has tried to fix this, maybe this will work for you.

i just tried it … it has the same issue