powered by Jive Software

Fastpath plugin missing in Spark

I am using spark 2.8.3 but and fastpath plugin missing do you know from where i can add it ?

Fastpath plugin is included with 2.8.3. Check in Program files\plugins. It is also extracted in C:\Users\user\AppData\Roaming\Spark\plugins. And finally in Spark go to File > Plugins menu. It should be listed in Installed plugins tab. If Fastpath tab doesn’t appear at the bottom of the window (to the right of Conferences tab), then your user is not a member of any queue or Fastpath is not running on the server.

Don’t bring up 10 years old topics.

I really applogize for bringing 10 year old topic sorry for that.

I am using ubuntu so couldn’t found above listed address and i have checked that agent is part of the workgroup as well as he can easliy join the room as well and room also joined one active participants but when i checked the workgroup it is showing “waiting to join”.

Also i have checked the spark plugins by going file - > plugins and only two plugins listed there was roar and Spellchecker.

Let me do one thing install spark on windows and then let me check if it help

Ah. Linux (and most probably macOS) version is problematic. Some plugins, like Flashing and other don’t work there. Maybe the same with Fastpath. I don’t remember if i ever tried it on Linux. Will have to take a look again.

I did small hack

I did installed spark on windows got fastpath.jar from above mentioned location and then copied jar to my ubuntu location (usr/share/spark/plugins) and restarted spark and it started showing fastpath tab in spark and working now.

Thanks fir your help :slight_smile:

1 Like

Hey @wroot,

Now fastpath seems working correctly request is coming to spark only one thing i can not understand after accpeting request whole spark application became unresponsive that i replicated for more then 5 time do you have any clue or solution what am i doing wrong ?

This is happening in both of the os windows and ubuntu.

I don’t have anything to suggest. Not using Fastpath (barely use Spark at all). When i try, i don’t see unresponsiveness. But incoming popup is blank, which is known and it seems also happens on very old versions of Spark, which worked fine before. So this might also be a server plugin’s issue https://issues.igniterealtime.org/browse/SPARK-1532

Fastpath is in a very bad shape in general and in Spark (not to mention that Spark as a project is not very alive). And i don’t know another client that works with queues. Maybe Pade does as Dele updated Fastpath Service plugin for some reason.

I have also checked and tar.gz archive has fastpath.jar included. Installing Spark 2.9.0 bightly build with deb installer also includes fastpath.jar file. But my Ubuntu 19.04 VM only has Java 11 and plugins don’t load with this version of Java.

Oh thanks for the udpate.

Yes you are correct it was generating the blank popup let me ask dele who has updated fastpath recently so he should have something to test.

Thanks for your time.