powered by Jive Software

How to configure the Meeting and Pàdé plugin?

Hello everyone, everything good?
I did some research here in the community, found some things, but could not configure properly. How do I configure the meeting plugin correctly so I can configure and use Pàdé?

When you put the address in the browser: https://IP_Server_Openfire:7443/ofmeet or https://DNS_name:7443/ofmeet the following error: ERR_SSL_VERSION_OR_CIPHER_MISMATCH.

Openfire 4.3.2, version of plugin Meeting is 0.9.5.

Thank You!

See https://igniterealtime.github.io/Pade/start.html

Need to set something up in Openfire? If so, how is setup done?
I ask this, because doing the steps of the tutorial, the result is the same as the reason for opening the call, is trying to establish the connection and does not connect, but also does not return any error message.

There could be so many reasons why

I am confused by your problem. Is the problem Openfire Meetings not working from your web browser or is the problem that you cannot make Pade connect to Openfire? I am not sure which problem you have?

Also, any screenshots or log messages will help to solve your problem.

Pàdé:

Does Pàdé not need the Meeting? Below is the print of the Meeting. But currently use inVerse normally.

Openfire:
image

In the Openfire log there is nothing! O bytes.

Pàdé tries to connect without stopping. If you leave it there, the session will expire!

Thank you for the screenshots. The problem is your server entered in Pade is not correct and the browser is trying to connect to a non-existing server. No connection is made with your openfire server.

Your server in Pade should be heab-intranet-linux.heab.local:7443 as shown in the FQDN info shown in the Openfire Server Information web page.

Got it! I made the change and it still does not connect!

Can you ping heab-intranet-linux.heab.local from the desktop? Otherwise use the ipadress:7443 for the server address and more impartantly, do you have a valid certificate on your heab-intranet-linux.heab.local server?

Pinging is done normally and I tried to put the IP as well. The result is the same as before.

Do you have a correct and working certificate for heab.local installed in openfire?

Yes, but self-signed.

It wont work!!!

You can only use self-sign for development and to do that you first MUST open a web page and force the browser to accept the certificate.

Open web page https://heab-intranet-linux.heab.local:7443 in chrome and accept certificate. After that, then try to login with Pade

I started getting this error last year too but I never looked into it. Now that a few months have passed and I’m looking again and seeing this error, I’m seeing that the certificate that the browser is offering me two certificates (and they seem to be two certificates which I have generated at some point for some project or other), but neither one is the same certificate being used by the openfire admin interface at port 9091. Does Openfire Meetings use a different certificate than the Openfire Admin interface? And if so, where can I set the certificate?
When I check the Admin panel under TLS/SSL certificates, I see that the certificate being used by the Admin interface on port 9091 is there in the Identity store.
The two that the browser is asking me about are not in that store, and there are no certificates in the Trust store.
Is it perhaps that Openfire Meetings is wanting identification from a local private key certificate, which should correspond with a public key certificate in the Trust store?

Actually, I simply tried hitting “save” in the SSL/TLS certificates management, and now everything is working again.