powered by Jive Software

IM Gateway + Bombus family clients =?

Has somebody tried to connect to gateways using that mobile clients? Server (openfire 3.3.3) becomes not responsible fot that connections. BTW, the connections from PC clients are well, the connections from Bombus while gateways are stopped are also ok.

I’m not sure what Bombus is nor have I ever tried them, but some of the folk I talk with regularly that use this plugin do mobile client development and things seem to be fine from their end. What PC clients are you referring to BTW?

Bombus is JAVA/MIDP - based client for cellular phones. You can find it here:

http://www.bombus-im.org/builds/046/midp2.0/Bombus.jar

http://www.bombus-im.org/builds/046/midp2.0/Bombus.jad

Attention! It may be with Russian interface while first time starting.

For the PC’s, I tried PSI, JAJC and Miranda.

I’m using Bombus on my Glofiish X500 - works fine with Openfire 3.3.1 & IM Gateway plugin 1.1.3a

3.3.1 ? Where can I find it now? (for WINDOWS)

Did you try this URL: http://www.igniterealtime.org/downloads/download-landing.jsp?file=openfire/openf ire_3_3_1.exe

Try using old SSL port (default 5223). Works for me

I’m also having a very similar issue. I use openfire exclusively as an IM gateway with bombus as the client to get around the price gouging for a native messaging client on my cell phone. Up to version 3.3.3 this setup has been working ASTOUNDINGLY. I have service through boost mobile which gives me a ‘true’ unlimited data plan at a max rate of 19.2kbps and either through java apps or tethering, I can do full socket connections with no problem. Before this issue, I used to be able to easily hold connections for hours on end with SASL enabled and reliably message contacts through the IM gateway plugin. No problems at all.

But I noticed that when I upgraded to 3.3.3 of openfire, I can’t get bombus to make a connection. Try default port 5222 with SASL, throws me a ‘login failed’ error. try it with no encryption, tells me invalid mechanism or something similar. SSL 5223 does absolute squat and sits at ‘opening stream’ which pre-empts login authentication.

I have even attempted reinstalling both bombus and openfire and have even went and installed the 3.4.0 beta of openfire with no such luck. I’d hate to have to go back to a dated version to fix this issue if there’s a fix to the current version available.

I’m “hearing” an aweful lot of complaints relating to Openfire 3.3.3 lately. Is there something actively wrong with that release that I should be aware of? The issues you describe I don’t believe directly tie into the gateway plugin itself, so in theory the plugin itself is ok. Does that sound right?

Well, I’m gonna have to do some more testing and get back to you. But I narrowed down one small aspect of the problem and that is, probably under my own mistake, the server name in the openfire configuration got set to the local machine name and not the dyndns address I had set up. Once I changed it and re-created the ssl certificates, a few problems cleared up. NOW…

With this now, keep in mind running openfire 3.3.3 with client encryption required, normal login on 5222 with SASL enabled, I don’t get login failed but it sits on ‘authenticating’ and does nothing. SSL is a crapshoot as I take it the built in JVM on the phone doesn’t support self-signed certificates as indicated by one of the J2ME errors it threw when trying it. cell signal SUCKS in my house so when it comes back up, I’ll try again and further help narrow this down. debug in openfire is currently enabled.

As well, I’m also gonna try a standard pc-based jabber client (specifically Miranda IM which has very verbose debug logging on it’s protocols.) and get back to you.

Ok. So here’s what I got. using bombus (the cellphone client), all I get out of the debug log is

2007.10.09 14:49:43 admin authorized to admin

Using miranda IM, I cannot get it to login either on SSL, TLS, or no encryption at all. Keeps throwing me ‘not authorized’. I also get a load of these in the Warn log:

2007.10.09 14:59:25
TLS was required by the server and connection was never secured.
Closing connection : org.jivesoftware.openfire.nio.NIOConnection@31086c
MINA Session: (SOCKET, R: /68.238.115.165:2504, L: /192.168.1.254:5222,
S: 0.0.0.0/0.0.0.0:5222)

And the debug log on the client side: http://pastebin.ca/731072

EDIT Also just noticed. The ‘TLS was required by the server’ message above. Noticed I have a ton of these including from the ip of the phone.

I also set client encryption to optional in openfire. PC client logs in fine. Bombus still sits at ‘authentication’. Both the pc and phone clients set to use TLS and SASL encryption respectively.

The issues you describe I don’t believe directly tie into the gateway

plugin itself, so in theory the plugin itself is ok. Does that sound

right?

Yes. This is right. even with the gateway plugin removed and just running a basic openfire setup, I still have the same identical issues. Don’t know why this thread is listed in the gateway support forum. Maybe it can be moved to have more eyes on it.

Howdy! I can actually move the thread, but it’s subject has IM Gateway in it so it might not get that much traffic. =) You may want to just post a new thread (if you want to continue the discussion) in the openfire support forum and refer to this thread. If you want me to move it though, just let me know and I will!

The same issues on removing?..

I don’t have such problem after removing the IM plugin, everything looks OK after it.

The same issues on removing?..

I don’t have such problem after removing the IM plugin, everything looks OK after it.

Wow I don’t freakin’ believe it! -MY- phone seems to be able to use it! (I’m amazed about this because my phone typically doesn’t support anything LOL)

Thanks to everybody for this discussion. I’ve downgraded to Openfire 3.3.1 with IM plugin 1.1.3a and everything goes OK =))))) Special thanks to prozector .

Well, I just wanted to add to this thread that there still seems to be some issues somewhere along the line here when dealing with the latest version of openfire and bombus. I have looked past any security issues as far as connecting is concerned since, well, I’m not running some super secret government intranet Im server.

Anyways, the issue I have noticed is that somewhere along the line either openfire, the IM gateway, or bombus itself, or possibly anything in between is not forwarding the full list of online contacts from the gateway plugin to the client. Using a native windows IM client that connects directly to AIM/MSN/etc., I easily have anywhere from 5-15 contacts online at any one time. But when I connect through the bombus client I only have a single contact come up which is the smarterchild bot on AIM. All transports show as online on the client side except MSN and when I try to force it to log in, it does not.

Now I also have mcabber which is a console based linux jabber client and it shows everything as it should. All transports connected, the expected list of contacts are online, etc… And tbqh, I have no clue where to start any possible debugging on this problem.

OR, if anyone knows of any, I’d certainly be willing to try an alternative J2ME jabber client if there is one available that plays nice with openfire. Thanks.

I also have this problem with Bombus, Openfire 3.4.2 + PyICQ-t as ICQ gateway.

I think there are errors in OpenFire and in Bombus both, because with other servers everything is ok

and with other clients everything is ok, too

when you say with other clients everyting is OK, do you mean with other j2me based mobile clients if so what j2me mobile client are you using?

For my part, I can’t connect anymore to Openfire since the 3.4.4 release with those clients. Both Bombus v0.5.1242 and BombuMod v0.5.1242.610M used to work with the former version of Openfire. Now the connections seems to freeze during the roster fetching which seems to never end.