powered by Jive Software

Introducing Project Pàdé- Openfire Meetings


#1

Pàdé is the Yoruba word for “Meet” and is also the name of a new project here at Ignite. Pàdé (the “p” is pronounced explosively) is the renamed Openfire Meetings Chrome Extension.

To install, visit the Google Chrome Store

You will need at least the following four openfire plugins to use it.

  • ofmeet
  • offocus
  • bookmarks
  • websocket (not needed if using OF 4.2)

Pàdé will fetch the logged in user’s contact roster as well as all the bookmarks configured for the user. To see, the contacts, conference rooms and web page urls, right click on the Openfire icon.

A normal left click on the Openfire icon causes Pàdé to open into a Jitsi Meet video-conference with the currently selected contact or multi-chat room.

If the meeting is with a contact, then the meeting url is sent to the contact as a standard chat message. When Pàdé receives such a message, it displays a notification to the user.

Accepting the invitation opens the Jitsi Meet video-conference window.


Introducing Pade - Openfire Meetings
#2

Very very nice idea Dele.
Anyway I’m keeping having problems on the standard ofmeet usage: trying to open any kind of room i receive this error:
“Ooops! Something went wrong ans we couldn’t connect to the conference; connection.otherError”.


#3

Thank you :slight_smile:

The first place to start is confirm you have a focus user created and logged in OK. This is done automatically by the ofmeet plugin, but sometime it fails especially if you are using LDAP. In such cases, you must create the user manually and make sure the user has permissions to administer MUC rooms.

Other than that, the JVB (Jitsi Video-Bridge) could have issues and Openfire logs and Chrome console log are your friends when that happens.

The old 0.3.x documentation may be a bit outdated for the new 0.4.x version, but some of the notes about installing and trouble shotting is still relevant.


#4

Hi Dele,
the ofmeet was working since 2 versions ago. The focus user was created on ad and logged in, i rechecked it now and i can confirm its connected and logged in.
I’ll cross check the logs even if the error arise immediately after trying to log in to the room, it does not happen using the chrome plugin…


#5

Hi, i already tried pade extension for chrome but still fail on connecting to my openfire server…
i can use ofmeet using firefox or chrome.

just to make sure what should i put on server and domain configuration page?
i tried this setup on pade:
server= http://xxx.org:7070/ofmeet/
domain= http://xxx.org

when i put my user and pass, configuration page automatically close but the pade icon still got off marking on it.


#6

Here are my settings. You don’t need the http:// prefix. WebRTC only works with SSL, so you have to use 7443 and not 7070 unless you have changed your ports in Openfire


#7

Wow, fast respond… thumb up!!..
i already change it to xxx.org:7443 as server and xxx.org as domain, the problem still the exist. Is there any log i can trace?
i just notice the icon is marked with off and kinda blinking per couple second. if i click pade icon it will open a blank icon and it will close automaticaly after 5-7 second.


#8

You might be missing the websocket plugin. Not needed if you are on OF 4.2. I should update the blog with that. Thanks.

Or, problem could be a missing certified SSL certificate for the wss: connection. You can use a self-certified certificate, but your would need to perform some extra steps. Not recommended unless you are developing.

Open your chrome console log to confirm which error messages. The blinking happens when it tries to reconnect and fails. If you don’t have a valid certificate.


#9

I have the same problem, can’t connect with this…


#10

It works now… :smiley:
Im still on Openfire 4.1.6, installing web socket is all it need…
Now its time to play with this thing… ill report if i find something…
Great Job…

Edit:
I spoke to soon, when i install websocket plugin my ofmeet is broken.

if i remove websocket plugin, ofmeet working again…


#11

Same issue, websocket breaks ofmeet.


#12

Pade is updated, now it have menu to enable or disable websocet. I pick disable websocket and pade could connect to my openfire server. But when i tried to make a videocall, there are error message like this:

When i inspect, its a websocket problem again. Maybe because ofmeet have internal websocket so it kinda not compatible with of websocket. Hope you find the problem so pade could be use on stable openfire server.

Also it would be great to have a basic feature like only show online user and search user feature


#13

Thanks for spotting that. It has been fixed in 0.1.7.
Can you record these ideas and suggestions on the GitHub project issues page.


#14

allready posted it, i hope i post it in a right way.


#15

Hi Dele,
I’m running OpenFire (4.21) - Meeting on a internet server (CentOs 7).
Plugins Meetings, Bookmark and Openfire Focus Provider are installed.
Centos firewall is disabled. DNS server is configured with SRV records for the services _xmpp_client e _xmpp_server.
Local and public address of Openfire Meeting are set to public ip address of my server.

It’s a fresh installation, with only two user, user_a and user_b.
user_a is in the roster of user_b, and user_b is in the roster of user_a.
user_a and user_b are members of the same chat room j0000xyz.
If two workstation (Windows 10), on two different internet connection, open with Chrome the url http://myserver:7443/ofmeet/j0000xyz, user_a can see user_b and vice versa (video and audio working).

Pade on the two Chrome is connected to myserver, but it doesn’t show any items under the items Meeting and Conversation of the menu called the right bottom of the mouse.

image

Both Chrome version is 63.0.3239.132.
I think something is missing, please help me.
Thank you,
Stefano


#16

In order to see the meeting room j0000xyz, create a groupchat bookmark with the bookmarks plugin

By default, roster users will show up under Conversations when they are online.

To change that, un-check “Show Only Online users” in options


#17

Thank you Dele, I solved the problem.
I created the bookmark, now I can see the room under Meetings.
When I captured the previous screenshot, the flag “Show Only Online users” was already uncheck.
Subscription “Both” was missing in the users belonging to the roster.
Stefano


#18

Nice concept & Idea. Also looking like very to use!! :slightly_smiling_face:


#19

Does Pade works without internet ? We have a network that is off the net. I can connect to Openfire server, it bring up the Chrome chat window and after a minute or so the page change to “There is no Internet connection … DNS_PROBE_FINISHED_NO_INTERNET”.

I am using latest Pade, Openfire 4.2.1


#20

Good day,
Can you please let me know if there is an offline version of Pade?
We have a closed environment and cannot download chrome extensions from the internet?

Thanks