powered by Jive Software

Issue with Spark client and AstraChat for iOS


#1

Hi,

I am currently having issues with sending messages from AstraChat (iOS) to Spark:

  1. The timestamp is always 01:00AM when sending messages.

  2. It’s showing “(Offline)” next to the user name on the chat session.

  3. The messages are arriving twice.

Capture.JPG


#2

what version of spark are you using, and do you see this behavior after returning from an automatic “away” or when returning from a locked desktop?


#3

The version is 2.7.6. I see this even when it’s active.


#4

Also, do you use Openfire as a server or is this AstraChat using something else (not familiar with that app).


#5

Yes I am using Openfire as a server.

I have also tried AstraChat with Pidgin and they work fine. So it’s definitely an AstraChat and Spark issue.


#6

In Spark do you use some custom presence status? Maybe you have set it to a negative priority? You can also try the latest build. Not sure on what OS you are using Spark, so here are two links:

Windows http://www.igniterealtime.org/builds/spark/dailybuilds/spark_2_7_6_807.exe

Mac OS http://bamboo.igniterealtime.org/browse/SPARK-NIGHTLYMAC-429/artifact/JOB1/Spark /spark_2_7_6_429.dmg


#7

No, I did not have any customization on Spark just the defaults only.

I just tried the latest build, still the same issue. Using Windows 7.


#8

Well, it must be something about AstraChat. speedy has a testing Mac OS virtual machine, maybe he can try it out and figure out what is happening. Is it happening with Pidgin-Spark combination though or Spark-Spark?


#9

Oh, you can also enable the debugger (Login window > Advanced) and post here a sample of xml when Spark received a message from AstraChat (remove private information before posting here).


#10

Raw sent:

a85n0x32176

a85n0x32176

a85n0x32182

a85n0x32182

a85n0x32187

a85n0x32187

Raw Received:

type=“chat”>7


#11

It’s not happening with other combinations, just Spark-AstraChat. But the weird thing is with Pidgin-AstraChat it works fine.


#12

I’ll try to test this as soon as I can. Currently waiting on the email link to download the application. :confused:


#13

Would be great to see more xml (Received part). And mixed with messages sent from Pidgin and from AstraChat. Even more great would be to see what AstraChat sends to the server, if possible. So far i see that server thinks that Spark user is offline and adds Delay tag and a time stamp (the time is not 1:00 AM) before sending it to Spark. Not sure why it thinks that Spark is offline and then the other second it thinks that is is actually online and delivers it. Could be Openfire issue as well. What Openfire version?

Not exactly the same, but looks like an issue with Openfire 4.x and Xabber Xabber Delivering only one way chat In this case messages are delivered after client restart.


#14

@speedy

The AstraChat app is free for mobile devices, I tried it in Android and it works fine. Only the iOS version of the app is having this issue.


#15

I am using openfire 4.0.2. The android version of Astrachat works fine with Spark, only the iOS. Below are the logs,

Astrachat on Android:

Hi

Online184943ba722d57d809b9707f57a81a8832d9cda76</ph oto>84943ba722d57d809b9707f57a81a8832d9cda76</ x>

Cool

Away1awaydf7be9dc4f467187783aca68c7ce98e4df2172d0</ph oto>df7be9dc4f467187783aca68c7ce98e4df2172d0</ x>

Online1df7be9dc4f467187783aca68c7ce98e4df2172d0</ph oto>df7be9dc4f467187783aca68c7ce98e4df2172d0</ x>

Away1awaydf7be9dc4f467187783aca68c7ce98e4df2172d0</ph oto>df7be9dc4f467187783aca68c7ce98e4df2172d0</ x>

Online1df7be9dc4f467187783aca68c7ce98e4df2172d0</ph oto>df7be9dc4f467187783aca68c7ce98e4df2172d0</ x>

Yeah

Astrachat on iOS:

Hahah

This

Strange!


#16

I did some further test and tried some of the previous builds, it worked on 2.7.3 (version 2.7.3.734 to be specific).

It started to show the bug from 2.7.4. Hope this helps.


#17

still waiting on a link to download the mac version. unfortunately, I don’t have an ios device to try this with.


#18

You can go to www.astrachat.com/desktop

Then use the code: camac


#19

I’m going with a buggy client on this one. I can’t get it to connect to openfire (keep getting encrytion error). I even tried a few different instances…I’ve tested other clients (jitsi, pidgin, spark, etc…) with my installs and none of them had any problems. The window client connects and prompts to accept my cert, but it rebooted my machine without asking during the install processes. not happy about that! I’m staying away from this client! Now I feel like I need to change all my passwords and scan my my machine! It did not leave me with any warm and fuzzies!


#20

Windows client is just a re-brand of Swift. I had Swift already installed and AstraChat installer said that i already have a newer version and quit Windows client works fine, no wonder. Their iOS client might be a re-brand of some good iOS open-source client, so it works fine because of that probably. Sadly, they chose to re-brand some buggy client for their Mac OS X version (or maybe it was actually their own product). I haven’t had a time to look at xml packets more closely.