powered by Jive Software

Jitsi blank screen

I just installed openfire 3.9 with the Jitsi plugin. When I create a video chat through Spark it opens up a link in Chrome, but the page is practiclly blank, see image. When I try to do a call with the Jitsi app, The call connects, but as soon as it does I get a pickup/hangup tone back to back, see screenshot.

I keep seeing stuff about OfMeet, but I don’t see any plugin for it on the plugin page or where to download the plugin. I’ve installed the system on Debian 7 64bit

java -version

java version “1.6.0_27”

OpenJDK Runtime Environment (IcedTea6 1.12.6) (6b27-1.12.6-1~deb7u1)

OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

Openfire does not have a Jitsi plugin. It does however have a Jitsi Videobridge plugin for video conferencing between Openfire users using OfMeet and Spark.

There will be a blog on how to use, but in the meantime. Here is blog that points out why Spark cannot make video calls with Jitsi just yet

http://community.igniterealtime.org/community/support/jitsi_videobridge_plugin/o fmeet/blog/2014/01/03/ofmeet-video-conferencing-application-based-on-jitmeet

Thanks, I read that before and there’s where I saw the mention of OfMeet. I’m still confused though, mainly on how do I get OfMeet. I do not see it in a list of plugins. How do I get OfMeet installed. I see that my jitsi_videobridge plugin is located at /MYIP/OfMeet/

The readme is very basic, but start from there

http://www.igniterealtime.org/projects/openfire/plugins/jitsivideobridge/readme. html

I will try and do a blog or document sometime soon. The release of 3.9.x caught me by surprise. I am still making changes to ofmeet and the jitsivideobridge plugin keeping it in sync with latestt code from the jitsi project.

I’ve been through all of that, though https://your_server:7443/ofmeet does not load in FF or Chrome. I am able to download the Spark plugin. Which when I go to start a conference with it, thought spark a page loads in chrom, but it is mianly blank, see my screenshot in the first update.

:/var/lib/openfire/plugins# ls

admin jitsivideobridge monitoring.jar redfire search.jar userimportexport

jinglenodes jitsivideobridge.jar rayo redfire.war stunserver userImportExport.jar

jingleNodes.jar monitoring rayo.jar search stunserver.jar

:/var/lib/openfire/plugins#

I need to see your Chrome console log. Please don’t say you are using an IP address for “your_server”.

In the console I get an error when going to the page.

Uncaught TypeError: Object [object Object] has no method ‘autosize’ main.js:52

No I"m going though by domian name. The server is on a public IP.

This is line 52 from main.js Not sure if you need the whole file or not.

$(’#usermsg’).autosize();

resizeLarge();

$(window).resize(function () {
resizeLarge();
});

Ok. we have a scripting error. I will raise a ticket

Just saw the updated Jitsi last night. Version 1.1.1. Installed it and it works great. Thanks for all the help.

Hello,

I have a error on the Chrome console:

ncaught SyntaxError: Unexpected token } :7443/ofmeet/js/config.js:12

My config.js is:

var config = {

hosts: {

domain: ‘dominio.net’,

muc: ‘conference.dominio.net’, // FIXME: use XEP-0030

bridge: ‘jitsi-videobridge.dominio.net’ // FIXME: use XEP-0030

},

useIPv6: false, // ipv6 support. use at your own risk

useNicks: false,

useWebsockets: false,

resolution: ‘360’,

bosh: window.location.protocol + // + window.location.host + ‘/http-bind/’

};

Any hint?

Regards

You need to add double quote to // in bosh url :

bosh: window.location.protocol + “//” + window.location.host + ‘/http-bind/’

Hello,

no more errors on Chrome but the page it’s the same: blank screen with at the bottom a square.

I don’t see errors on openfire logs so I don’t know where to look to resolve the problem

Regards

url in the browser has to be identical to your domain name in config.js

hello,

if my domain is dominio.net the correct url would be:

https://dominio.net:7443/ofmeet

right?

Regards

depends on the version. with latest version 1.2, URLs have changed it would be

https://dominio.net:7443/jitsi/apps/ofmeet

Hello,

the error was Anonymous access not enabled.

Now working fine.

Thank you

Hello, I have this error in chrome to access the ofMeet: WebSocket connection to ‘wss://65.x.x.x:7443/ws/server?username=null&password=null&resource=htb8no4pa7g 2pgb9’ failed: Error during WebSocket handshake: Unexpected response code: 404

I’m using openfire 3.9.1 + jitsivideobridge 1.2.

I’m usign address as in doc: https://65.x.x.x:7443/jitsi/apps/ofmeet/

Show a blank web window with the a bue bar on the top, just that.

This is my config in /opt/openfire/plugins/jitsivideobridge/apps/ofmeet/js/config.js:

===============

var config = {

hosts: {

domain: ‘65.x.x.x.x’,

muc: ‘conference.65.x.x.x.x’, // FIXME: use XEP-0030

bridge: ‘jitsi-videobridge.65.x.x.x.x’ // FIXME: use XEP-0030

},

useIPv6: false, // ipv6 support. use at your own risk

useNicks: false,

useWebsockets: true,

resolution: “360”,

bosh: window.location.protocol + “//” + window.location.host + ‘/http-bind/’ // FIXME: use xep-0156 for that

};

================

What is wrong?

Thanks

Hello,

are you installed websocket plugin?

If not change:

useWebsockets: true,

to

useWebsockets: false,

Or dowload websocket.war. On Linux:

cd /opt/openfire/plugins

wget http://community.igniterealtime.org/servlet/JiveServlet/download/38-23429/websoc kets.war

Restart Openfire

Regards

Hello,

Yes, I did exactaly as you told me. I follow the http://community.igniterealtime.org/docs/DOC-2693 doc

root@sp4936k:/opt/openfire/plugins# ls -la

total 23020

drwxr-xr-x 6 root root 4096 Feb 18 11:08 .

drwxr-xr-x 11 root root 4096 Feb 18 10:56 …

drwxr-xr-x 3 root root 4096 Feb 6 16:40 admin

drwx------ 7 root root 4096 Feb 18 11:01 jitsivideobridge

-rw-r–r-- 1 root root 21672533 Feb 18 11:01 jitsivideobridge.jar

drwxr-xr-x 4 root root 4096 Feb 18 11:08 jitsivideobridge-plugin

-rw-r–r-- 1 root root 28789 Feb 18 11:08 jitsivideobridge-plugin.jar

drwxr-xr-x 5 root root 4096 Feb 18 10:56 search

-rw-r–r-- 1 root root 33346 Feb 6 16:39 search.jar

-rw-r–r-- 1 root root 1799518 Feb 7 14:57 websoc

root@sp4936k:/opt/openfire/plugins#

Now I tryed “useWebsockets: false,” in config.js and works. =D

Questions:

1 - What parts/functions of ofMeet will not works if I have Webosckets disabled (false)?

2 - I really still not understand what is the difference between ofMeet and the JitMeet. They has the same design and functions and both works just on chorme (webrtc). Could you explaim me?

3 - I trying since yesterday to do a short url for the JitMeet and not sucess. I would like to substitute the https://65.x.x.x:7443/jitsi/apps/ofmeet/ to just something like https://65.x.x.x:7443/meet.html as are this example on the internet https://webrtc.free-solutions.org:8443/videobridge.html or better the https://meet.jit.si/

I see something to edit the openfire/resources/spank/index.html. But I not understand how to do that. I tryed many many times. Could you point one doc how to do that or one example?

Thanks so much!

Hello,

my directory look different:

drwxr-xr-x 3 root root
4096 feb 6 16:40 admin
drwx------ 7 root root
4096 feb 18 04:52 jitsivideobridge

-rw-r–r-- 1 root root 21672533 feb 18 04:50 jitsivideobridge.jar

drwxr-xr-x 6 root root
4096 feb 13 18:18 monitoring

-rw-r–r-- 1 root root 1732341 feb 13 18:18 monitoring.jar

drwxr-xr-x 5 root root
4096 feb 13 17:51 search
-rw-r–r-- 1 root root
33346 feb 6 16:39 search.jar
drwxr-xr-x 5 root root
4096 feb 13 17:55 userimportexport

-rw-r–r-- 1 root root 287297 feb 13 17:55 userImportExport.jar

drwxr-xr-x 7 root root
4096 feb 18 05:42 websockets

-rwxr-xr-x 1 root root 1799518 feb 7 14:57 websockets.war

I think I forgot to put in the howto this command:

chmod + websockets.war

before restart openfire

I’m going to fix it

I don’t know how answer your questios. Maybe Dele do.

Regards