powered by Jive Software

Jitsi Meet app (android and ios) use openfire server?

Anyone tried using the new Jitsi Meet app (android and ios) to connect to their own private openfire server rather than to their server?

I think it only connects to meet.jit.si website

a post on the jitsi mailing list [jitsi-users] Thank you for your helping jitsimeet react-native for mobile

“You can use the Jitsi Meet app in the Play Store and use the full URL instead of just using the room name and it will connect to your server.”

Not sure what the full url would be?

You are absolutely correct. and it does work, but only with the unreleased version 0.4.xx of Openfire Meetings. For more details, see my blog.

Openfire Meetings - Update

I’m trying to put the full url of my private server (https://calamatitech.info:7443/ofmeet/j0000xyz) in the room field of the Android app, but when I push the Join button the app tell me:
"You have been disconnected. You may want to check your network connection. Rejoining in 30 seconds …"
When I connect from a PC using Chrome everything is working.

My Openfire version is 4.21, Meeting 0.9.2, Focus Provider 0.9.2, and Bookmarks 1.0.
Openfire is configured to accept anonymous xmpp connections.

Any suggestions?
Thank you,
Stefano

I think is a problem of ssl certificate.
The url is working in IOS.
I will try other CA (now I using Let’s Encrypt)

It is not a ssl certificate problem.
I tried a ssl.com certificate (free for 90days), which is android compatible from version 1.5, but the joining to the room https://calamatitech.info:7443/ofmeet/j0000xyz again fails.

I go back to square one.
It’s a certificate problem, because joining to room https://calamatitech.info:7070/ofmeet/j0000xyz was successful.
Shall I setup the plugin ofmeet to support the ssl certificate?

Problem solved. I created a new keystore(JKS format) for OpenFire with Key Store Explorer.
I added to the keystore the complete path of root and intermediate CA to the domain validated certificate.
(AddTrustExternalCARoot, USERTrustRSAAddTrustCA, SSLcomDVCA_2).
I also added these three certificated to the trusted CA of Android (Only AddTrustExternalCARoot was already present).

This helped in solving the issue.
I used the existing keystore and appended the cert (step 5)

/opt/openfire/resources/security/keystore

On Android app I keep getting the Red screen error You have been disconnected.

I am not understanding the certificate. Does the phone and openfire need new certificates?

I got same problem, our server use Let’s Encrypt SSL, and we followed advaitian steps.
Website connection ok, but failed at mobile connect to server.
Please help what is the problem is?

1 Like

Hi, I have the same problem, have you tried Buy a certificate from another certificate provider?

I use SSL certificate from sslforfree.com.
There should be 3 files.
1. certificate.crt
2. private.key
3. ca_bundle.crt

Step 1: import first 2 files via Openfire Admin console
Import Private Key and Certificate under TLS/SSL Certificates tab
Step 2: copy /opt/openfire/resources/security/keystore to desktop
Step 3: using http://keystore-explorer.sourceforge.net open keystore
password is changeit
Step 4: Append the file 3 (ca_bundle.crt) to certificate imported in step 1
Step 5: save the changes to keystore.
Step 8: move the updated keystoke to server /tmp
Step 6: Stop openfire
Step 7: replace /opt/openfire/resources/security/keystore with updated /tmp/keystore file.
(backup original just in case)
Step 8: Start openfire