powered by Jive Software

Jitsi ofmeet app error


#1

Hello,

I’m trying to deploy the jitsivideobridge-plugin and I have some problems.

I have:

  • Openfire 3.9.1
  • Jitsi Video Bridge Plugin 1.2
  • WebSockets Plugin 0.0.0.07

Using the ofmeet app I got an error when trying to connect to specific room:

rayo colibri register got error

rayoCallback

When someone comes to a room is like he is in another room, there is no change in the web. Every one sees his own video but nothing more.

Because I don’t know if is obligatory to have a room in the conferences server with the same name I have created it but the result is the same.

Thanks for advanced,

Roger


#2

Edit config.js and make sure your use of server.domain.es and domain.es is correct


#3

this is the content of my config.js:

var config = {

hosts: {

domain: window.location.hostname,

muc: ‘conference.’ + window.location.hostname, // FIXME: use XEP-0030

bridge: ‘jitsi-videobridge.’ + window.location.hostname // FIXME: use XEP-0030

},

useIPv6: false, // ipv6 support. use at your own risk

useNicks: false,

useWebsockets: true,

resolution: “360”,

bosh: window.location.protocol + “//” + window.location.host + ‘/http-bind/’ // FIXME: use xep-0156 for that

};

I forgot to say that I changed the real server and domain names for ‘server’ and ‘domain’ strings.

Regards,


#4

I forgot to say that I changed the real server and domain names for ‘server’ and ‘domain’ strings.

Whatever you changed is still not correct. jitsi@conference.server.domain.es should be jitsi@conference.domain.es

hosts: {

domain: ‘conference.domain.es’,

muc: ‘conference.domain.es

bridge: ‘jitsi-videobridge.domain.es

},


#5

hy,

The changes I made only was when I copy the log to de discussion. The config.js file is from the original plugin.

I have changed the config file and it works now the chat is working, the room is created in the xmpp server, but the video is not.

I get no errors from javascript.

Any idea?

Thanks for all,


#6

look at your openfire log files. you might have issues with the jitsi videobridge plugin on your OS


#7

yes, I was just looking at javascript errors.

At the logs I have:

2014.03.13 12:58:08 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler occupantJoined qoa2l4pbxx0f6r@conference.domain.es 0lempaw9vsra4i@domain.es/0lempaw9vsra4i eu0ocjbcwfav2t9

2014.03.13 12:58:11 org.jivesoftware.openfire.muc.spi.LocalMUCUser - Chat client attempted to access unimplemented feature

thanks for all,

Regards


#8

You need to find your Jitsvideobridge log. It is normally wriiten to stderror

On Linux, this may end up on the screen/console if you do not re-direct it to a file

On Windows, the file stderror.log is created automatically.


#9

hello,

I activated the debug log options from the web management and I get some more logs:

When the first participant enter in the ofmeet web i get this: http://pastebin.com/rxssr3kW

When the second participant enter in the ofmeet web (same room that first) I get this: http://pastebin.com/3ebpBqZ5

I don’t know if it is important but the system is a debian 6.0 and the openfire was intalled from the deb package dowloaded from the ignite website.

Thanks for all the help,

Regards,


#10

Does not look like you read my last reply

You need to see what has been logged to stderror not debug.log


#11

sorry, I send you the debug logs because I cannot get anything in the stdout.

I start openfire with this command:

/usr/lib/jvm/java-6-sun/bin/java -DopenfireHome=/usr/share/openfire -Dopenfire.lib.dir=/usr/share/openfire/lib -classpath /usr/share/openfire/lib/startup.jar -jar /usr/share/openfire/lib/startup.jar

I get this: http://pastebin.com/kRzL1tGu

but I get no logs when I start a new conference, all the logs are from the startup of openfire.

Thanks for the help,

Regards


#12

You should get more logging after you start a conference. I am no Linux expert, but I think you can add

mylogfile.log

to your startup command


#13

I get no more logs.

to make tests I execute the openfire server in a console, the output is showing in it. If I redirect the output all I will get is the same but in a file.

I have tried it again and there are no more logs.

Any parameter to set from the jitsi config o openfire config to get that logs?

Regards,


#14

If Jitsi videobridge component is not producing any more messages, it means it is not recieving any requests. Check your config.js again and confirm jitsi-videobridge.domain.es is correct. Then check your info.log file to confirm the messages are sent.


#15

I have checked config.js, it is ok:


var config = {

hosts: {

domain: ‘conference.domain.es’,

muc: ‘conference.domain.es’, // FIXME: use XEP-0030

bridge: ‘jitsi-videobridge.domain.es’ // FIXME: use XEP-0030

},

useIPv6: false, // ipv6 support. use at your own risk

useNicks: false,

useWebsockets: true,

resolution: “360”,

bosh: window.location.protocol + “//” + window.location.host + ‘/http-bind/’ // FIXME: use xep-0156 for that

};


When the server is started jitsi print some logs to the stdout (all startup logs http://pastebin.com/kRzL1tGu)

After that all I can find are this logs:


2014.03.18 08:57:45 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler occupantJoined test@conference.domain.es kpy67onezk7w4s4i@domain.es/kpy67onezk7w4s4i l3nqtqop931

2014.03.18 08:57:47 org.jivesoftware.openfire.muc.spi.LocalMUCUser - Chat client attempted to access unimplemented feature

2014.03.18 08:57:49 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler nicknameChanged test@conference.domain.es kpy67onezk7w4s4i@domain.es/kpy67onezk7w4s4i

2014.03.18 08:58:00 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler occupantJoined test@conference.domain.es 7x44lva2w0ugcik9@domain.es/7x44lva2w0ugcik9 roger(13w6g

2014.03.18 08:58:00 org.jivesoftware.openfire.muc.spi.LocalMUCUser - Chat client attempted to access unimplemented feature

2014.03.18 08:59:40 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler occupantLeft test@conference.domain.es 7x44lva2w0ugcik9@domain.es/7x44lva2w0ugcik9

2014.03.18 08:59:40 org.jitsi.videobridge.openfire.PluginImpl - removeColibriChannel 0

2014.03.18 08:59:44 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler occupantLeft test@conference.domain.es kpy67onezk7w4s4i@domain.es/kpy67onezk7w4s4i

2014.03.18 08:59:44 org.jitsi.videobridge.openfire.PluginImpl - removeColibriChannel 0

2014.03.18 08:59:44 org.jitsi.videobridge.openfire.PluginImpl - ColibriIQHandler roomDestroyed test@conference.domain.es


I tried to set jitsi-videobridge.domain.es in the hosts files of the clients but same results.

Thanks for all,


#16

Can you confirm you are NOT running jitsi videobridge as an external component


#17

yes, I can confirm that.

In Sessions -> Active sessions -> Components Sessions -> Connected external components: 0

I have only installed the plugin and changed the config.js. I don’t know if the plugin must be an external component or not.

Regards,


#18

<iq xmlns=“jabber:client” to=conference.domain.es type=“set” id=“2570:sendIQ” from="kpy67onezk7w4s4i@domain.es/kpy67onezk7w4s4i">

This message is wrong. It should be sent to jitsi-videobridge.domanin.es and not conference.domain.es

Are you sure you are editing the correct config.js file?


#19

the config file I edited was: /var/lib/openfire/plugins/jitsivideobridge/apps/ofmeet/js/config.js

I have checked in the browser debugger that config.js is correct:

Regards,


#20

your domain is domain.es and MUC is conference.domain.es