powered by Jive Software

Mac OS X Build

Is there a build for OS X yet? I have searched the site and found nothing about OS X, but the jabber project page says that OS X is a supported OS for jive??

Ken

Ken,

We don’‘t have a build or installers specifically for OS X yet. However, the tar.gz package should work well with OS 10.4 (Tiger) as long as you’'ve installed JDK 1.5.

Regards,

Matt

Are there any install docs speciefic to OS X??

Unfortunately, no, but that’‘s something we’'d love to add.

Regards,

Matt

Just thought I’‘d add my experience here trying to set up jive_messenger in mac. This isn’‘t a tutorial, cause I haven’'t figure out how to make it work, but maybe it can help the developers get a better idea on how its running with Mac, and maybe someone can even tell me what I can do to get it running.

I’‘ve followed the instructions for installing the jive messenger on Linux, and I’'ve extracted the archive to /usr/bin.

When I try and run the “messenger” script I get this:

No suitable Java Virtual Machine could be found on your system.

The version of the JVM must be at least 1.5.

Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.

You can also try to delete the JVM cache file /Users/Brandon/.install4j

I’‘ve installed the JDK 5.0, set it up so the 5.0 JVM should be running, and I’'ve even set it up so java should compile with with the JDK 5.0.

I’'ve also tried sending it to the JVM using the command:

$ java messenger

which gives me:

Exception in thread “main” java.lang.NoClassDefFoundError: messenger

that’‘s it. If anyone has actually installed this on Mac OSX, it’'s be good to hear about how you did it.

Hi mbdayton,

Are you sure you have the JDK setup properly? What happen’'s when you type java -version at the command prompt?

Thanks,

Ryan

java version “1.5.0_02”

Java™ 2 Runtime Environment, Standard Edition (build 1.5.0_02-56)

Java HotSpot™ Client VM (build 1.5.0_02-36, mixed mode, sharing)

Hmm… strange. Sounds like something isn’'t configured quite right. Did you trying deleting or moving the /Users/Brandon/.install4j file?

Thanks,

Ryan

I’‘ve been able to get Jive Messenger to build and run fine under OS X 10.4. The trick was to make sure that Java 1.5 was installed (and it sounds like you’'ve done that) and to make sure I set the JAVA_HOME env variable at the command line before running any of the scripts. I use this:

export JAVA_HOME=’’/System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home’’

Ant works fine after this as does running Jive Messenger scripts. You can also add this line into the .sh scripts if you get tired of typing it in everytime.

Jeffthewookie,

That did the trick! Lunch is on me next time you’'re in Utah.

thanks,

Brandon

No problem Brandon. I’‘m doing Jive dev on OS X so we should share tips. Don’'t have any plans to go to Utah, but I might hold you to that some day.

Maybe we could start by writing some install instructions for OSX.

Hi,

i type java -version, and get this:

java version “1.4.2_09”

Java™ 2 Runtime Environment, Standard Edition (build 1.4.2_09-232)

Java HotSpot™ Client VM (build 1.4.2-54, mixed mode)

is the mixed mode ok, or how can i activate version 1.5? I installed it, but when i go to “java preferences” to change the used version, nothing happens

Any ideas?

thanks

Hi kleinerschwabe,

Changing the version in Java Preferences utility only affects applets and network launched applications (JNLP). To set Java 1.5 as your default version follow Jeff’'s instructions above,

export JAVA_HOME=’’/System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home’’

Hope that helps,

Ryan

Hi Ryan,

i have done this several times before asking (typed it in the terminal, copy-paste-it), without any effect.

So i think there is something else wrong, but what?

What do you see when you type:

ls /System/Library/Frameworks/JavaVM.framework/Versions

?

i get this:

1.3 1.4 1.5 A CurrentJDK

1.3.1 1.4.2 1.5.0 Current

Strange. Well, there is something that you can to set your default java version to 1.5:

• Open Terminal.

• Because you’'re going to be modifying System information, you need to identify yourself as the administrator by typing: sudo su root

• Terminal will prompt for the admin password. Enter this.

• Change the current directory by typing: cd /System/Library/Frameworks/JavaVM.framework/Versions

• Within this directory, there is an alias called CurrentJDK. By default, it is aliasing the 1.4.2 directory. You need to remove this alias by typing: mv CurrentJDK OldJDK

• Now you need to replace it with a new alias pointing to the 1.5.0 directory instead. Do this by typing: ln –s 1.5.0 CurrentJDK

• Finally, log out of the session as administrator by typing: exit

Thanks,

Ryan

Hi Ryan,

thanks a lot for your help. Now i have java version 1.5.0

All i have to do now is to find out why jive wont work. after downloading the jive messenger tar.gz i extract it and copy it to usr/bin

But how can i start the messenger? in the install-guide they write:

You can start and stop Jive Messenger using the bin/messenger script in your Jive messenger installation:

  1. ./messenger

Usage: ./messenger {start|stop}

  1. ./messenger start

Starting messenger[/i]

but the terminal told me something about command not found. Are the commands under OS X a bit different? testing it with safari (http://127.0.0.1:9090/) safari told me it cant connect to the server (http://127.0.0.1/ works fine and show the apache screen)

Regards

kleinerschwabe

Message was edited by:

kleinerschwabe

but the terminal told me something about command not found

Do you know what the exact message was? A copy of the message should be in either the log files or in the nohup.out file.

Thanks

Ryan