powered by Jive Software

MacOS replace deprecated installer[NEED TEST]

Hi all =)

macOS single bundle is deprecated. This media file type is deprecated because of signature requirements in modern macOS versions. We must use the single bundle archive, but we need to test this change on Mac OS X and modern MacOS to maintain compatibility.

Unfortunately I don’t have a MacBook. Someone please try installing the latest nightly build of Spark on your Mac and let us know how it went, it will help us a lot.

Jira ticket: [SPARK-2299] - Ignite Realtime Jira

I’ve given it a go today on two Macs.

i7 Macbook running macOS 13
m1 Macbook running macOS 12

On the m1, lots of warnings about not being able to verify the signature.
On the i7, no such problem.

On both, only the bundled JRE version worked.
The plain version gave errors about not finding a JRE - presumably a 64bit problem?

On both, first launch was poorly themed. I’ve not tested on the m1, but on the i7, quitting and relaunching fixed all of this.
image

Let me know if there’s further / better tests I can run.

Hmm, interesting. By the way, in Spark 3.0.0 mac with JRE we use 64 bit Java. Perhaps it is very old for the latest versions of Mac OS, can I ask you to replace the JRE folder with this one?
<jreBundle jreBundleSource="preCreated" includedJre="macosx-amd64-1.8.0_202" />
This is the latest version of JRE x64 for macOS

JRE.rar (33.3 МБ)

I made a Spark 3.0.0 installer with Universal Architectures. Please try to install it.

By the way, the FlatLaf developer suggested to me that in MacOs we use a different LaF - JTextField.placeholderText on MacOs · Issue #617 · JFormDesigner/FlatLaf · GitHub

Can you try installing to this version? And also show what Laf you have chosen.

Sorry for the slow response.

The universal app didn’t help on the m1 mac.
image

The updated FlatLaf build didn’t help.
I’ve tried to document the content of the spark.properties, steps taken and how it looked using the Terminal below. I’m not sure it’s quite come out as useful and usable as I wanted, but hopefully does it well enough to get the states across, and, importantly, that the LaF isn’t populated until the Advanced menu is opened (although the UI doesn’t look wildly different)

~|⇒ cd ~/Library/Application\ Support
Application Support|⇒ cat Spark/spark.properties
cat: Spark/spark.properties: No such file or directory

Application Support|⇒ echo Launching Spark for the first time
Launching Spark for the first time

Application Support|⇒ cat Spark/spark.properties
#Spark Settings
#Thu Dec 01 14:44:37 GMT 2022

Application Support|⇒ echo Quitting Spark
Quitting Spark

Application Support|⇒ cat Spark/spark.properties
#Spark Settings
#Thu Dec 01 14:44:37 GMT 2022

Application Support|⇒ echo Launching Spark again
Launching Spark again

(same again)

Application Support|⇒ echo Opening Advanced menu
Opening Advanced menu

Application Support|⇒ cat Spark/spark.properties
#Spark Settings
#Thu Dec 01 14:45:14 GMT 2022
LookAndFeel=org.jivesoftware.spark.ui.themes.lafs.SparkLightLaf
hostAndPort=false

Ooh, that’s progress!

Application Support|⇒ echo Pressing OK
Pressing OK

Application Support|⇒ cat Spark/spark.properties
#Spark Settings
#Thu Dec 01 14:45:44 GMT 2022
allowClientSideAuthentication=true
compressionOn=false
resource=Spark
useVersionAsResource=false
acceptRevoked=false
hostAndPort=false
acceptExpired=false
DisableHostnameVerification=false
timeout=10
xmppPort=5222
useHostnameAsResource=false
debuggerEnabled=false
checkCRL=true
allowSoftFail=true
checkOCSP=false
protocol=SOCKS
proxyPassword=
xmppHost=
proxyEnabled=false
acceptSelfSigned=false
ssoMethod=file
proxyUsername=
sslEnabled=false
securityMode=ifpossible
ssoEnabled=false
acceptNotValidYet=false
saslGssapiSmack3compat=false
LookAndFeel=org.jivesoftware.spark.ui.themes.lafs.SparkLightLaf

Application Support|⇒ echo Quitting Spark
Quitting Spark

Application Support|⇒ echo Launching Spark again
Launching Spark again

Better

Do you want results from the Intel Mac now as well, or work on one at a time?

Hmm, maybe I got it wrong. Try the night build please. Just before that, delete the file with the settings.

On the m1, the nightly with JRE was happy on first launch :+1:

glad to hear it. For the sake of experiment, try it on intel) the only thing I don’t understand is why Spark doesn’t see Java on your macbooks …

How does Spark attempt to detect java and its version?
There’s a bajillion ways to install Java, and lots of different flavours and bundlings of Java SDK nowadays too.

I think only install4j knows about it :smiley:
I think install4j is looking for JAVA_HOME

You need to install Java (not unpack) so that the install4j installer can see it.

Try to install any x64 installer for MasOS(.pkg)