powered by Jive Software

No admin console logon with 3.4.0 or 3.4.1 upgrade

I still can’t log into the admin console after upgrading to either 3.4.0/3.4.1 from 3.3.3. Users appear to be able to connect to the server, but I can’t get into the console.

Have you verified that the user you are tryin to use is in the openfire.xml as an admin? Have you removed any plugins from the server that may be inconpatible?

I am also unable to get to the admin console logon page after the upgrade

I have removed all my plugins except admin, then it works

I copied the openfire.xml file over from the previous install. It is possible it is a plug in problem. I did download all the most recent plugins from the site, with the exception of the Spark Manager. I’ll take another shot at it this weekend, when people aren’t using the network.

If you’re authenticating against a directory and use an “AND” LDAP search to find the user object, I believe there is a bug in the Openfire v3.4.0 and v3.4.1 admin UI that will add and extra “amp;” for the “&” character in the search string. Recheck the

Nope. No LDAP. Using just the MySQL DB.

I am using LDAP integration but i have searched openfire.xml and can’t find a

<searchFilter> reverence like you listed. I am using the local database as well. Again, i got my admin console to work by disabling all plugins except the admin console. I’ll try the plugins 1 by 1 later today.

I had Ryan Graham’s MOTD plugin that is version specific

Ok. It still won’t work, and here’s what I’ve tried (upgrading from 3.3.3 to 3.4.1):

First, I stop OpenFire 3.3.3 and rename its directory to something else. I then extract 3.4.1. I copy over ONLY the openfire.xml file and nothing else. I restart the service & users can connect to the server but the admin console is locked out.

I then tried running the set up & tried to reconnect. Failed. The set up process did work, but when the time came to log into the admin console: no go.

The only thing I did notice was in the set up screen (the one where the lightbulb will appear in your tray), I did get a message that the databases had been upgraded from version 11 to version 13.

Even after the DB upgrade, the admin console still doesn’t work.

Any ideas? Anything you’d like to see from my system?

I had the same problem. Login was only possible with http and not via https.

I upgraded my servers JAVA-JRE and now it works fine.

I’m running the most recent JRE (1.6.0u3) and I’ve only ever used http, never https.

I’d really like to get the system upgradeed, as we keep experience outages that have never happened before. Clients are randomly disconnecting from the server. (Clients: Spark 2.5.7, Server 3.3.3).

Have you tried re-running the setup (change the tag to false and restart Openfire and open the sdmin console)? I have had some database issues that wouldn’t let me log in with the existing admin account and doing that fixed it…

one of my installs of openfire 3.4.1 I had to loggin as admin and password admin instead of the my admin password then it worked fine after that

Yes. I tried that. I had it rerun the set up & I get the same problem. People can connect to the server to chat, but I can’t connect to the admin console. The screen comes up, and no matter what I give it for a user name and password, it won’t let me in.

Tried that too. No luck.

I had that happen to that clients could not login but I could login to admin I fixed this by down grading back to 3.3.3.Then I Installed the 3.4.1 to a different dir. and a new database as a new install.then I exited the 3.4.1 and started 3.3.3 and used the export client and imported it to the new server 3.4.1 now can log admin & clients in.

Could not get the update for 3.4.0 or 3.4.1 had to use the new install.So recommend new install method.

wont matter if you get into admin your clients wont login with the upgrade method.

Bruce

I’ve though about doing this. The problem is, I will loose all my group memberships. I’m using the MySQL DB option versus LDAP (dear god I wish I could use LDAP, but that’s another argument). I’ve got a bunch of users in various groups tyo maintain global contact lists. It’s REALLY time consuming if I have to redo all of that.

If push comes to shove, I’ll do it. But I so hope I don’t have to.

I am having a similiar problem. Here is my background and issue. Fresh Install of openfire 3.4.1 in windows server 2003 R2. The openfire install was done with the embedded DB and Active Directory. Thru-out the setup in testing the environement everything passed—the base dn, administrator dn, samaccounts, groups all seem fine. After install I can launch the admin console and login fine as me. At this points clients can attach and everything seems fine

The probelm occurs after I restart the application and then login into the admin console I get declined. I varified that the username is in the admin list, the only plug-in is the search one. And no default settings were changed. In addition at this point the clients cannot attach either.

Additionally we are behind a corporate firewall that is not allowing any traffic out or in at this point.

One additional coincident is that if i go to the setup before restarting the application under security certificates there is a banner at the top of section that states that the web server needs to be rebooted. Once I do that the admin console closes and the login denies me.

Export your users list from openfire admin goto users/groups user import and export then export user data to file -Save user data to the specified file location.

click export.do this and keep up to date and you can rewrite you mysql database without los of users.Next do a new install of openfire 3.4.x to a new dir so you have both server and you can start one or the other as you like until you satisfied the new server is ready to take the full load of your messenger.I have both I switch back then import your user data then your users data will be in both server.Then open your mysql databaes for your 3.3.3 openfire and fined export your users groups and impot to the new server I recomend using heidisql to do this as it is simpler than most editors

and forth as the new server 3.4.1 jwchat dos not work yet but thats another story

Hi,

do you still have the old mysql.jar file which was delivered with 340?

In 341 a new driver was supplied and it seems to cause some problems which may or may not be related to your problem.

LG