powered by Jive Software

Openfire fires repeatedly same never ending debug and trace logs

I have two server in a cluster. Server 1 fires following debug messages since days repeatedly. Only a restart of openfire stops it for a while but the it starts over and seems never ending.
While is doing so no client updates its roster. So new created user wont see there roster, while existing user wont see new user in their roster.
Server 2 is pretty quiet instead.

2022.06.10 13:30:58 TRACE [hz.openfire.cached.thread-1]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - CallableTask[org.jivesoftware.openfire.cluster.RemotePacketExecution] result: null
2022.06.10 13:30:58 DEBUG [hz.openfire.cached.thread-5]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - Executing asynchronous DistributedTask: org.jivesoftware.openfire.cluster.RemotePacketExecution
2022.06.10 13:30:58 TRACE [hz.openfire.cached.thread-5]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - CallableTask[org.jivesoftware.openfire.cluster.RemotePacketExecution] result: null
2022.06.10 13:30:58 DEBUG [hz.openfire.cached.thread-15]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - Executing asynchronous DistributedTask: org.jivesoftware.openfire.cluster.RemotePacketExecution
2022.06.10 13:30:58 TRACE [hz.openfire.cached.thread-15]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - CallableTask[org.jivesoftware.openfire.cluster.RemotePacketExecution] result: null
2022.06.10 13:30:58 DEBUG [hz.openfire.cached.thread-4]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - Executing asynchronous DistributedTask: org.jivesoftware.openfire.cluster.RemotePacketExecution
2022.06.10 13:30:58 TRACE [hz.openfire.cached.thread-4]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - CallableTask[org.jivesoftware.openfire.cluster.RemotePacketExecution] result: null
2022.06.10 13:30:58 DEBUG [hz.openfire.cached.thread-15]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - Executing asynchronous DistributedTask: org.jivesoftware.openfire.cluster.RemotePacketExecution
2022.06.10 13:30:58 TRACE [hz.openfire.cached.thread-15]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - CallableTask[org.jivesoftware.openfire.cluster.RemotePacketExecution] result: null
2022.06.10 13:30:58 DEBUG [hz.openfire.cached.thread-5]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - Executing asynchronous DistributedTask: org.jivesoftware.openfire.cluster.RemotePacketExecution
2022.06.10 13:30:58 TRACE [hz.openfire.cached.thread-5]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - CallableTask[org.jivesoftware.openfire.cluster.RemotePacketExecution] result: null
2022.06.10 13:30:58 DEBUG [hz.openfire.cached.thread-1]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - Executing asynchronous DistributedTask: org.jivesoftware.openfire.cluster.RemotePacketExecution
2022.06.10 13:30:58 TRACE [hz.openfire.cached.thread-1]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - CallableTask[org.jivesoftware.openfire.cluster.RemotePacketExecution] result: null
2022.06.10 13:30:58 DEBUG [hz.openfire.cached.thread-5]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - Executing asynchronous DistributedTask: org.jivesoftware.openfire.cluster.RemotePacketExecution
2022.06.10 13:30:58 TRACE [hz.openfire.cached.thread-5]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - CallableTask[org.jivesoftware.openfire.cluster.RemotePacketExecution] result: null
2022.06.10 13:30:58 DEBUG [hz.openfire.cached.thread-15]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - Executing asynchronous DistributedTask: org.jivesoftware.openfire.cluster.RemotePacketExecution
2022.06.10 13:30:58 TRACE [hz.openfire.cached.thread-15]: org.jivesoftware.openfire.plugin.util.cache.ClusteredCacheFactory - CallableTask[org.jivesoftware.openfire.cluster.RemotePacketExecution] result: null


Maybe there is some kind of NullPointer reference that’s causing issues. Can you provide a thread dump that is taken when this is happening?

Seems it refers to issue ISSUE.
It happens after logging in on the converse.js, if there is no device list for the user but a bundle.
I have seen it in the console of the browser. (Failed to fetch device list).
Once this happens the OF starts spitting these debug logs.
So, I followed your advice to run a single app server with converse.js due to the libsignal license problem.
But I do have the same issue with converse like I had with inverse.(libsignal was integrated with a script tag in inverse)
The device list is not published properly. There is a bundle created for the browser session but the device is not beeing updated. I dont have any clue why this is happening. Could it be a network issue?


Do you see something weird here?