powered by Jive Software

OpenFire login problems after upgrade

Im using OpenFire and SQLSERVER for Spark. I have recently updated to 4.2.3 and can no longer log into the Admin Console with the same credentials is used previously. When I look in the openfire.xml file I can see the encrypted username and password, but I still cant log in.

Is the admin console login stored in the database, or just in the xml file? I dont see the password hash in the database, so I suspect not. Also, I have another instance running in another location, and the admin password hash on that system doesn’t appear in that database either.

Is there a way to create a new admin login?

There are a number of ways to create new admins, but that would be a workaround for the real problem. I suppose you already have reverted to previous installation from backup? Then you can try upgrading again. What OS is Openfire installed on and what version did you have originally? If it is very old, then it is better to do incremental updates. Explanation: upgrading Openfire

Hi
Unfortunately I have inherited this problem. There is no backup and no way to revert back, hence I am stuck with creating a new admin. OpenFire is installed on Windows server 2008 standard. I don’t know what the previous version was as I didnt do the upgrade, i just need to get this working and the person who did the upgrade isn’t here for 2 weeks.

Adding or deleting admin accounts to Openfire this is one of the threads from the search. You can add a user via authorizedjids in openfire.xml.

Thanks. I added that but still cant login

I still get the error Login failed: make sure your username and password are correct and that your an admin.

There was no password in the example script?

Adding via openfire.xml doesn’t require password. I haven’t ever tried to add users directly to the database.

what i did notice was that the xml file had changed to add the new users, but when i tried to log in it removed them.

Openfire reads them, adds to the database and then removes them. I’m afraid it will be hard to investigate this issue. It might be that upgrade was faulty and corrupted something. Btw, you say that you are not able to login to admin console, but what about clients? Can they login, chat?

Hi,

Firstly, thanks for your support on this. I will check that the accounts are being added, I suspect they aren’t. We are talking about the SQL Server database and not some other OpenFire database I don’t know about?

Point that may be of some value is that the original version was in program files x86, the new is in program files. Also, I’m not convinced it was upgraded and not deleted and reinstalled as 64 bit.

With regards to Spark: I can log in but none of the chat rooms are available. Also, when I open OpenFire it has found old database version 25 and is upgrading to version 26 for OpenFire 4.2.3

Openfire has one database (either external one like MySQL or MSSQL, or internal/embedded one). So, original version was x86 and was installed in x86. If you ended up with an install folder in non x86, then it might be the case i have described in the guide above. You probably have two installs of Openfire now. And you try to run the new one, which is empty (no database) and that’s why you can’t login, although that doesn’t explain how clients are able to login. You can try running the uninstall in the non x86 folder, then run a version in x86 folder (if it is still there). It probably will be some older version. If it is not there, then that person upgrading Openfire did some stuff, maybe moved files from older installation to new one after the fresh install of 4.2.3 and then deleted the old folder. But maybe not everything was moved and maybe that’s why it gives errors about database.

As this is with external database, maybe when new x64 installer was launched it didn’t find the old installation and it provided the initial web setup and then the person upgrading it pointed to the same database, but it didn’t hook to it normally for some reason.

I guess you can just try to uninstall and wipe all traces of Openfire and do fresh install and try to connect to the same database. If you have database credentials.

Also, make sure you don’t have two instances of Openfire running as it might already be running as a service.

Thanks, that was a great help. In the end I moved to the DR server, which hasn’t been used for a while, but it works. Users are logged in and working. the only issue is that they can only see 2 days worth of messages in Spark, whereas previously they could see more. Ideally we would like to go back a week of messages available. How do I increase the number of days messages?

Once i have done that I will rebuild the old Openfire by uninstalling and re-installing it.

I have replied in your other thread. If this is in group chat, then maybe you should check group chat history settings. Admin Console > Group Chat > Group Chat Settings > click on your conference server > History Settings. Although it only has a setting for a number of messages, not how old they are.

In regular chats there is no setting in Spark to show two days or longer. If previous history is enabled it will show 10 last messages in the chat window. But whole history should be available in History window.

A post was split to a new topic: Clients can’t connect after update to 4.2.3