powered by Jive Software

Openfire server is running, but no Contacts are shown in SPARK

Hello,

I have a Server Connection - withe the WEB-Admin Concole on openfire I can see all the users I Need within my Company,

but all users have an empty SPARK window.

Could you please help me ? I am moving in circles since yesterday morning and I can not get a clue on it.

best regards,

Axel

When did this happen? Maybe you have updated or changed something? Or is it a new installation and you don’t know how to share all users to all?

Hello,

last Saturday we have been working on Group Folder Restrictions - but I do not think that this is reated to the SPARK-Problem.

When I open the WEB-admin window I can see all our contacts

Yesterday in the afternoon I received this error message:

2017.02.07 17:11:30 org.jivesoftware.database.DbConnectionManager - Unable to get a connection from the database pool (attempt 10 out of 10).

java.sql.SQLException: Cannot open database “openfire” requested by the login. The login failed.

at net.sourceforge.jtds.jdbc.SQLDiagnostic.addDiagnostic(SQLDiagnostic.java:368)

at net.sourceforge.jtds.jdbc.TdsCore.tdsErrorToken(TdsCore.java:2816)

at net.sourceforge.jtds.jdbc.TdsCore.nextToken(TdsCore.java:2254)

at net.sourceforge.jtds.jdbc.TdsCore.login(TdsCore.java:602)

at net.sourceforge.jtds.jdbc.ConnectionJDBC2.(ConnectionJDBC2.java:344)

at net.sourceforge.jtds.jdbc.ConnectionJDBC3.(ConnectionJDBC3.java:50)

at net.sourceforge.jtds.jdbc.Driver.connect(Driver.java:182)

at java.sql.DriverManager.getConnection(Unknown Source)

at java.sql.DriverManager.getConnection(Unknown Source)

at org.logicalcobwebs.proxool.DefaultConnectionBuilder.buildConnection(DefaultConn ectionBuilder.java:39)

do you have any idea ?

best regards,

Axel

When you see all the users in Admin Console, go to Groups link at the top and check if you have any groups. Then check if you have users in those groups. And then check if Sharing is turned on for those groups (otherwise they do not show up in clients):

As you mentioned you had problem with your database, maybe you database got corrupted and groups information disappeared.

Hello,

thanks for your quick Response,

i have noticed that there are no Groups - I tried to create two Groups, but:

I am logged in as admin, and when I try to create a Group, I get this error message:

Not allowed: the Group account System is read-only

how can I proceed ?

best regards,

Axel

So you are probably using LDAP integration and all users and groups should come from your AD. I’m not sure as i don’t use AD integration. I think groups should be imported from AD also. So, if you had groups before, then something changed either on AD side or with your AD integration filter in Openfire.

I checked the SPARK dir on my PC and found this in my log files:

SEVERE - "unable to load plugin.org.jivesoftware/smack/XMPPEsception: unsupported Major.minor Version 51.0 Java Lang unsupported Class Version Error: org/Jive Software/smack/XMPPException:unsupported Major.minor Version 51.0

what does this mean to me ?

best regards,

Axel

Such errors are usually shown when unsupported Java version is used. Does your Spark has jre folder in its folder? Or do you use online installer and install Java separately?

Yes - I do have a JRE Folder within my SPARK directory

Then Java version should be ok. Maybe this log entry is old and not relevant anymore.

I found this on Openfire Server log:

2017.02.22 14:53:43 org.jivesoftware.openfire.ldap.LdapGroupProvider - Groupname Online not found

org.jivesoftware.openfire.group.GroupNotFoundException: Groupname Online not found

Well, it can’t find group “Online” on your AD server. Which was probably used to import users. You mentioned that you were doing something with group restrictions. Maybe this is related. Maybe this group was removed or its permissions changed. Not sure what to do next. You can probably rerun Openfire setup and configure LDAP connection from scratch. Can’t help with that. Never did this and have no experience with LDAP filters.

Hello,

who has experience with the LDAP Connection to spark an can help me here - I am really stuck. The collegues can not Chat anymore…

Where can I check the responsible configuration ?

best regards, Axel

@speedy is quite competent, maybe he will have some ideas. You can also try to catch him in our group chat here.

I’m not so sure about that!

First make sure your groups are showing in your openfire console. If not, then they will not show in spark. with ldap intergration, the groups must be managed from there. Once you create your groups and add users to them, you then have the option to create the “shared roster” groups per wroots instructions

Hello,

there are no Groups in my openfire console - although I am logged in as admin, I can not create any Groups since the System tells me

“System Groups are Read Only”

how should I proceed ?

bes regards,

Axel

Speedy, it seems to me that his ldap config vaporized or they changed something on their AD so it can’t access groups anymore. Maybe he will have to rerun the setup.

Axel, you are seeing that message because your server is setup to pull users and groups from AD. In such case ability to create groips manually in Admin Console is disabled. You have to manage users and groups in your AD.

ldap intergration is read only, so you will not be able to add groups from openfire. This must be done in ldap.

you’re issue is likely with the ldap search filters

you should look at your settings for ldap.baseDN, ldap.groupSearchFilter, and ldap.searchFilter

It might easier to run through the setup again. These changes can lock you out if not done correctly. If you’re using the embedded db, simply back this up before making changes to easily revert. If you are using mysql or ms sql, you can edit the tables directly if you need to.