powered by Jive Software

PyMSNt on Windows 2k

I am reposting this question because I realized I tagged it onto a post that was really already answered. Sorry for posting in the wrong spot (and then re-posting).

I am trying to set up PyMSNt, but am not having much luck. I followed the instructions online, but am getting the error message below. If anyone has an idea of what I could be doing wrong, or could post me their working config file I would appriciate it.

Also, Do I have to add anything to the WildFire config file to tell it to use the PyMSNt ??


C:\Program Files\Wildfire\transports\pymsnt>python PyMSNt.py

Unable to install any good reactors (kqueue, epoll, poll).

We fell back to using select. You may have scalability problems.

This reactor will not support more than 1024 connections +at a time.

Could not find the XML DOM. If you’'re using Twisted 2.x make sure you have twist

ed.words installed.

Traceback (most recent call last):

File “PyMSNt.py”, line 11, in ?

import main

File “C:\Program Files\Wildfire\transports\pymsnt\src\main.py”, line 36, in ?

import xmlconfig

File “C:\Program Files\Wildfire\transports\pymsnt\src\xmlconfig.py”, line 4, i

n ?

from tlib import xmlw

File “C:\Program Files\Wildfire\transports\pymsnt\src\tlib\xmlw.py”, line 77,

in ?

from twisted.xish.domish import SuxElementStream, Element, unescapeFromXml

ImportError: No module named xish.domish


Peter

How exactly did you install this and what did you install with it?

I followd the instructions on this page (and installed everything it said to install)

http://delx.cjb.net/pymsnt/docs/server.html

Wel … almost. I just realized I did not install py Openssl, and PyCrypto. So I just did that.

THe output I now get is this:

C:\Program Files\Wildfire\transports\pymsnt>c:\Python23\python PyMSNt.py

Unable to find a reactor.

Exiting…

Also. The instrustions on this page do not tell you how to edit the server file for Wildfire (but do have examples for other servers). Do I have to edit the Wildfire config?

I can start over if it is better ? I have perl2.3, pyOpenssl 0.6, pycrypto, twisted 2

I am also not completely sure what I am supposed to have for a JID.

I put the servers IP address.

Also, Do I only need to configure this file: (for the wildfire server)

C:\Program Files\Wildfire\transports\pymsnt\config.xml

Or do I need to config this one too.

C:\Program Files\Wildfire\transports\pymsnt\src\config.py ?

Thanks

Peter

Hey Peter,

Last time I used PyMSNt was with version 0.9.3. Anyway, I would say that the only file that you still need to modify is config.xml. There are 4 variables that you need to correctly configure in that file.

jid --> The value has to end with your server name. E.g.: msn.myserver.com

mainServer --> The server name of your Wildfire server. This value is used by the gateway to know where the server is so it can open a socket connection

port --> This value has to match the port that you configured in the admin console of Wildfire for external components.

secret --> This value has to match the secret that you configured in the admin console of Wildfire for external components.

From the Wildfire side all you need to do is click on “External Components” (in the admin console), enable the service, specify the port and secret to use. You can also enable the debug log to see how components are connecting to the server.

Regards,

– Gato

Thanks for the detailed responce.

I am still a bit unsure for the jid.

I do not have a registered server name … so do I just put an IP there? or do I put msn.ip or msn.some_made_up_name.com

Also, Do I have to add an external component into the admin ? Or just enable it ?

I still seem to be getting the same error message …

Thanks again.

peter

Hey peter,

I do not have a registered server name … so do I

just put an IP there? or do I put msn.ip or

msn.some_made_up_name.com

If you are going to use server-2-server communication then you MUST use a resolvable name (e.g. myniceserver.com) and register DNS SRV records in your DNS server. However, if you will just use it internally then you may keep using your IP server address as your server name. Once you have decided which server name to use you MUST use that value as part of the jid in PyMSN. E.g. server name = myniceserver.com then jid = msn.myniceserver.com.

Also, Do I have to add an external component into the

admin ? Or just enable it ?

Just enable it and make sure to use the same port and secret in PyMSN. If there is going to be a firewall between PyMSN and Wildfire then make sure that the port that you will be using is not being blocked by the firewall.

I still seem to be getting the same error message

Sorry about that. The comments in my post are not meant to solve those specific errors . Those errors seems to be related to your PyMSN setup. Since they are PyMSN setup specific I highly recommend looking for help in PyMSN forums: http://www.modevia.com/cgi-bin/mailman/listinfo/py-transports

Regards,

– Gato

Hello again. look at this one and then look at your. with exception of names and passwords this is a working script. Jeff

<!8011>

<!http://host.com/msn/files/>

THe output I now get now is this.

C:\Program Files\Wildfire\transports\pymsnt>c:\Python23\python PyMSNt.py

Unable to find a reactor.

If I open a client up, I do not see the transport…

have you installed a reactor? on Linux it can be left default, but I am not sure if Windows has anything to handle that or not. I know that epoll is a reactor to try.

Jeff

Where do I get epoll ??

opps sorry that is Linux only, but hey take a look at this thread. seems there are some dll’'s that must be there…

http://www.jivesoftware.org/community/thread.jspa?threadID=18439

I got much further !!! (I think)

This is the output I get now.

C:\Program Files\Wildfire\transports\pymsnt>c:\python23\python PyMSNt.py

Unable to install any good reactors (kqueue, epoll, poll).

We fell back to using select. You may have scalability problems.

This reactor will not support more than 1024 connections +at a time.

Unknown reactor: select . Using select(), reactor.

WARNING! Only PNG avatars will be understood by this transport. Please install t

he Python Imaging Library.

Here is my current config file. I can not see the transport in my client … and I am not sure where to look for it on the server. Thank you so much for all of your help.

ok. in the jid put

and remember the port number.

In wildfire external componants

add your msn.ip_to_your_server in the connection box, pay attention to the secret for both (same) and make sure the ports are the same. Yes you are getting further. the polling error says that it can;t find but has reverted to a lessor which is good enough to get it runnign for now. the PNG errors means that you don;t have the Imaging library installed (google PYTHON IMAGING LIBRARY)

restart MSN and see what happens…

Jeff

Thanks for the help.

The only things I have under External COmponents on the server is Port, and Default Shared Secret. Where is the connection box ???

Thanks

Peter

opps, sorry the box where you enter the data… that is area for connection info. sorry for the confusion. do both of these look the same (connection info on server and connection criteria for MSN in the .xml file?) if s stop and start msn and see where that gets you…

jeff

No problem for the mistake … I make them all the time … My problem is I can not find where you enter the connection infor on the server … I know … I am thick …

left side of the webinterface> server setings>external componants>allowed to connect>subdomain{msn.your.server.ip.addy} shared secret

you can shoose to allow all things to connect using the port at the top of that page or using the white list (which I do) allow only the externals that you specify in those fields to connect.

Jeff

Man, THank you again for your help … but I think I am a lost cause.

I do not know what I am doing wrong. I have the settings the way you said … but I still do not see how to make psi (or gaim) connect to use msn.

I do appriciate your help. If there is any other info you can give me, it would be very much appriciated …

Ok. So do you login to the server using these clients? First and foremost GAIM will not register a client. Sorry if you said that and I missed it. Are you using Windows? if so get a client that supports discovery (i don;t use psi so I don;t know if it does)

if both are configured all that needs to be done is to register with the client through the wildfire server. Windows or Linux?

Jeff