Red5 standalone sip

Hi ,

I’ve set up a Red5 standalone server to test the sip phone. Install was fine, but when i’ve tried to test, the phone succeded with every IP to register whith (for the sip server).

2 accounts were created, an xlite with one account and the flashphone with the second one. each account is without any password.

I can call from the flashphone to the xlite, but i can’t call back. I’ve got an error not found when i try to call.

When looking at the log of the asterisk server, I can see the registration of the xlite softphone, but the flashphone never. When i call from the flashphone, there is a log, the account is correct

I can’t have access to the asterisk configuration (sorry it’s for my intern, so i don’t have access to everything) so i don’t know how it was set up.

Oh other information : red5 and xlite are installed on my computer (xp) and connecting to a distant sip server (dedicated for tests)

If you need any other information (log or anything else) i’ll post it

thank you

I had a similar problem but with the openfire server and red5 plugin. Try calling from xlite to user2@yourred5server:5070 as it worked for me.

Basit Ali

Thank you , I’ll try this today

edit : it works , thank you


Can you please describe in a step by step how to run Red5 SIP without openfire, I mean, as a standalone application?

Best Regards,



Download red5 standalone on their website (

on the right you will find the paquet you need.

I’ve began by the windows version, installed on my computer, the next step was to follow this site :

the only thing was, for me, to reboot my laptop at the end (there is a glitch on my computer with the start/stop of a service)

Everything worked on windows computer, but on debian, when I replace the red5.jar the server won’t launch again anymore, so, if someone has an idea or have an answer, it will be very helpful, I need to deploy it on a debian server

I’ve tried the following steps for setting it up. These were copied from red5-server/

  1. Install Red5 Server

You can Download from these site RED5 Download Link

  1. Download file from following link and unzip it, move the sip folder to webapps (where u installed Red5 Server path)

SIP Application for Standalone Red5 Server is

You will need to replace version 0.7 red5.jar with the latest from SVN or this

Check the Red5 server( Start service of Red5 Server if it is not start)

Run red5phone application with http://localhost:5080/sip

See this document


It still doesn’t work.

The rtmp:/sip connection doesnt not work to the red5 server fromt he flash clients it does not send out registers or any sip.

I’m running on Linux.

Does anyone was able to run it on Linux as a standalone?

Best Regards,



I think your problem could be this:


You should instead enter


I am trying to make standalone red5 (latest SVN) with red5phone (latest SVN with small fixes) working on debian, and I can initiate SIP calls, but I get no media either way (The flash caller can send DTMF whistles to the SIP party though)

Check out the issues section st

Red5phone standalone is currently broken with red5 SVN. You will find contributed code fixes for this, but I have no intention of working on it until red5 server 0.7.1 is released. If you are using red5 server 0.7.0 with, then it should work. I have it working under Windows and others have got it working with Linux (not sure of which flavours)

Watch out for asa2ulaw, which you have to recompile and check the sip.log file in the logs folder as well as the jetty stdout.log where it is on your Linux.

Yes, I have read that, but making it compile was so easy, I though I could make it run :slight_smile:

(I do understand the VoIP side of things quite well.)

I’m trying to get hold of a windows machine to try it there.

Here are my simptoms when trying to follow the procedure on linux:

I download the linux distribution (0.7.0), runs fine.

If I replace red5.jar with the supplied one, I get an excetion about jetty classes missing from it.

I thought this might have to do with configuration, so I extracted the red5 0.7.0 windows installer with wine, but the configuration (and the exception) were identical.

I understand you don’t wish to bother with this until the underlying API stabilises somewhat, but I’m impatient :slight_smile:

I’d like to ask for one simple clue: where it runs for you, is the embedded web container jetty or tomcat?

Thanks, and double-thanks for making and sharing the red5phone project!

Bahh, I just added the jetty jars to the classpath and now it starts up :slight_smile:

I guess it should work from here, modulo the de-windowsifying patches :slight_smile:

The line in I changed:

exec $JAVA -cp red5.jar:conf:$CLASSPATH:lib/jetty-6.1.7.jar:lib/jetty-util-6.1.7.jar:lib/jetty -xbean-6.1.7.jar org.red5.server.Standalone

Sorry about the noise, and a big big thanks to all OS contributors out there!


I’v copy / paste your modification on the

and the red5

don’t start, i’ve got the error : -xbean-6.1.7.jar

Unrecognized option: -xbean-6.1.7.jar
Could not create the Java virtual machine.

Maybe something is wrong on my installation , I’ve took the tar version of red5 (0.7.0) untar it and made every change, I was blocked on the same point (java exception) and the modifications, I think, must be adapted for every installation.

I’m trying to make it work with a jdk 1.6.0_07 maybe there is a relation


My bad, can’t paste “preformatted” text here yet. An extra whitespace has been introduced into the name of a jar file. Let me try again:

exec $JAVA -cp red5.jar:conf:$CLASSPATH:lib/jetty-6.1.7.jar:lib/jetty-util-6.1.7.jar:lib/jetty-xbean-6.1.7.jar org.red5.server.Standalone

I can’t seem to find the preview button, sorry of this comes out worse than before…

So in that command the -cp (classpath) option is a colon (:slight_smile: separated list of actual jar file names (and a directory).

Thank You

It worked perfectly. You saved me a lot of useless search.

Thank you

You are welcome, that’s the least I could do.

Let me know how it works for you.

You’ll also have to make assets/codecs/asao2ulaw executable, and rename it to asao2ulaw.exe :

cd webapps/sip

cp assets/codecs/asao2ulaw assets/codecs/asao2ulaw.exe

Some creative directory linking will also be needed unless you are willing to recompile the sip classes with a small fix…


I’ve performed tests on the server. I can establish a call between two clients. I have sound (the ringing bell) but when I pickup the call, I have no sound from the microphone.

Maybe the sound is a bit too low, I’ve made a make in my src directory and moved the asao2ulaw file (which was executable) but I didn’t rename it with a .exe

Server was restarted but no change.

I’ve performed a test with a softphone like xlite to see if I can have a voice from this software, but everytime I establish the call, it is drop, I think due to a media negociation failure. I’ll check in the configuration file of red5 (I’ve disabled every video codec in xlite ) for the audio codec, maybe if I force xlite to use only one codec, it may works.

I have another issue, but it will be more questions, and I will focus on the sound problem today, if someone have an idea

Thanks in advance


I’ve perfomed some tests.

Firstly, when I read all the community threads, I think that I am the only who have a red5 server which don’t send any voice. When I compile my files, cp and chmod it, no sound, either way , from flash to soft or soft to flash… When I call from xlite to flash, the call hung up immediatly, with a media negociation error, despite the fact i’ve enabled every audio codec available and disable all the video one. But still no change.

And when I made a call between two flashphone, I still have no sound…

I’ve made some tests on the openfire platform with the red5 plugin. I’ve made a call from softphone to flash without having made the operation for codecs and the call passed. But when I put the codecs in their directory, same error as above, can’t negotiate.

Another issue, is when I’ve made a call, the sound works for one call. After that, I have to make a rm of the asso2ulaw codec and make it another time with a start / stop of the server…

I’ve not performed yet the call between two flash phone, but having followed the tutorial for deploying openfire, I thought it will work…

I can post the log you need if you have an idea

Thanks in advance

Hi again,

I finaly made mine work today with a minimum amount of compiling followin the instructions here:

I had to recompile the nellymoser to PCM transcoder (I even copied it to the .exe name for good measure…)

You probably won’t need to recompile SIPUser.class like I did if everything (red5, your SIP proxy and other SIP endpoint) run on the same machine.

just in case you have a problem with the loopback address in the SDP, here’s what I changed:

I changed the SipProvider constructor to read the config file:

sip_provider = new SipProvider(configFile);

so I could add this to sip.cfg this:


Thanks for sharing your experience and supporting other users on this.