powered by Jive Software

Sip Phone Plugins

Hey,

I’m trying to use Sip Phone pluing, but when I click the test button is SIP phone mappings I receive this error:

SIP Account problem: NetworkErrorCheck the Registrar Address, and if there is a firewall blocking OpenFire Server to reach SIP Registrar Address.

And I found this in the stdoutt.log:

==> stdoutt.log <==

start - javax.sip.PeerUnavailableException: The Peer JAIN SIP Factory: gov.nist.javax.sip.address.AddressFactoryImpl could not be instantiated. Ensure the Path Name has been set.

  • org.jivesoftware.openfire.sip.tester.comm.CommunicationsException: Could not create factories!

Anybody can help me ?

Thanks.

1 Like

Hello,

Can you tell me which version are you running?

Cheers,

Thiago

Hello Marcelo,

Thanks for the bug report. It’s already fixed, you can go to your Openfire admin Console and Update the SIP Plugin from there.

Best Regards,

Thiago

Are you talking about version 1.0.1 ???

This version is the one that is not working for me. I’m using Openfire 3.4.1.

Thanks.

Ok, I found the version 1.0.2

But now when I’m trying to test the sip mapping, I receive this error:

SIP Account problem: TimeoutAttempt timeout, please try again.

And nothing in the logs.

Any idea ?

Thanks

So, i have same problem with SIP Phone plugin. Now it writes “Attemp timeout, please try again”.

P.S. What i need to set in Voisemail field if i havent voicemail?

P.P.S. May set Diplay Phone Numer as a e-mail like address or PSTN number?

Hey,

That message is telling you that your Openfire Server could not reach the SIP Server setup for the account.

If your SIP server is located inside an intranet, and your openfire is located at internet, unless you setup your network for a one-to-one NAT, Openfire won’t reach you SIP server.

What’s your setup?

Cheers,

Thiago

My Openfire server is running in the same machine as the Asterisk server.

Hello,

Can you tell me how many network interfaces your server has?

Can you check if your server can discover the SIP server IP from the DNS located in the same machine?

Did you try testing accounts from external SIP servers such iptel.org etc… ?

Best Regards,

Thiago

P.S. What i need to set in Voisemail field if i havent voicemail?

Just leave it blank

Cheers,

Thiago

My server has 3 eths.

The DNS I’ll have to check, but I discover that I can connect in a server from one of our clients without problems, so the problem is here in our server.

Another “problem”: the test works fine for my sip account, but it continue to appear unregistered in the mappings list.

BTW, another problem is that I install the SIP plugin in Spark but never appear in the installed plugins list…

Same trouble with timeout message here as well. Anyone actually see this work yet? It doesn’t seem spark even hits my sip server based on sip server logs…

I’m receiving this info in stdoutt.log:

register - org.jivesoftware.openfire.sip.tester.comm.CommunicationsException: Could not send out the register request!

Now I’m trying with 2 different computers. One is the openfire server and the other is the asterisk server.

Any ideas ?

Thanks

I just discovered for me it actually does work. It just never registers or allows call control on the top of spark window. The trick was to make in inbound call to myself and I was surprised to see it ring and give me a chance to answer. Once I receive a call then the call control window stays open. This obviously needs to be fixed, but it sorta works for now as a trial…

But in the openfire admin console, in the SIP phone mapping, when you try to test a mapping is it working ?

I recieve a timeout…

I get the timeout error too. Try calling yourself and see if it works. What type of sip server/itsp are you using. I am using my own Zultys MX250 in my office.

Well, but even if works like this, I don’t know how to install the sip plugin in Spark. It is not working…

Folks

I’ve installed SIP Phone Plugin(1.0.2) on my Openfire Server 3.4.1 and also created an account on SIP Phone Mapping. When I connect using Spark 2.5.8,

the dial numbers don’t appear on it. The connection between my Asterisk Server and Openfire is OK.

OpenFire Server 3.4.1 on SuSE Linux

Database: Oracle Database 10g Enterprise Edition Release 10.2.0.3.0

Any Idea?

Regards

Eduardo

I have an asterisk server setup in a remote office behind a firewall. The asterisk server is on the dmz.

My openfire server is on another server many miles away in another office behind a firewall.

I had the same problems as most of you, but I got mine to work…except on Leopard… sprark crashes as soon as the call is answered.

How I fixed the other problems

Log into your asterisk server and edit the sip.conf file

add these lines.

nat=yes

externip=your_public_ip

localnet=192.168.X.0/255.255.255.0

localnet= any other local nets on the asterisk server.

Thats all I had to add to get mine working.

Here is my entire sip.conf file

context=default ; Default context for incoming calls

bindport=5060 ; UDP Port to bind to (SIP standard port is 5060)

nat=yes ; If your behind a NAT, Router or Firewall you need this.

bindaddr=0.0.0.0 ; IP address to bind to (0.0.0.0 binds to all)

externip=Your_External_Public_IP ; This is your public internet IP address

localnet=192.168.168.0/255.255.255.0 ;localnet are not passed via NAT (you must declare your local LAN )

localnet=192.168.101.0/255.255.255.0 ;must delcare all your local lan

srvlookup=yes ; Enable DNS SRV lookups on outbound calls

tos_sip=cs3 ; Sets TOS for SIP packets.

tos_audio=ef ; Sets TOS for RTP audio packets.

tos_video=af41 ; Sets TOS for RTP video packets.

maxexpirey=7200

defaultexpirey=3600

minexpiry=60 ; Minimum length of registrations/subscriptions (default 60)

;t1min=100 ; Minimum roundtrip time for messages to monitored hosts defaults to 100 ms

;checkmwi=10 ; Default time between mailbox checks for peers

disallow=all ; First disallow all codecs

allow=ulaw ; Allow codecs in order of preference

;allow=alaw

allow=g726

allow=gsm

allow=g723.1

;allow=g729

allow=ilbc ; Note: codec order is respected only in

language=en ; Default language setting for all users/peers

;progressinband=never ; If we should generate in-band ringing always

dtmfmode=rfc2833 ; Set default dtmfmode for sending DTMF. Default: rfc2833

callevents=yes ; generate manager events when sip ua performs events (e.g. hold)

canreinvite=no

jbenable = yes

; jbforce = no

jbmaxsize = 200

; jbresyncthreshold = 1000

jbimpl = fixed

; jblog = no

Hello All,

SIP Phone Mappingsjust map SIP accounts, it don’t creates SIP accounts in your SIP server.

You must create your SIP account in your SIP Server, and bind them to your users in openfire. Make sure you enabled the accounts in SIP Mapping Account Settings.

The registration in the SIP server depends exclusively on your SIP Serve, Openfire just push the account settings to Openfire users.

Spark SIP Phone plugin, only works on MAC and Windows.

Best Regards,

Thiago