Spark 2.0 Released

We are very pleased to announce the release of Spark 2.0. Some of the new features include:

  • Open Source under LGPL (removed all commercial “pieces” for a pure open-source client)

  • Full I18N support

  • Online/Offline/Typing notifications in the contact list

  • Stale chat support (tab management)

  • New UI for Invitations and Broadcasts

  • Bookmark support

  • Improved plugin API (easier to implement custom plugins)

  • Quick Links bar (buttons on top)

  • Notification preferences (toaster popups, window focus)

  • Gateway support (buttons show up when connected, etc)

  • Optimized numerous aspects of the client for improved speed

  • Open Source under LGPL

  • Logout with reason

  • Improved Look and feel




Hi kindly let me know when I can expect integrated SSO.

Since version 2. +

using Control - N

to search for names does not work anymore.

The ‘‘find contacts’’ window comes up

but when entering a letter to search on

or pressing enter nothing comes up.

Can this please be fixed.

Worked great in ver 1.1.4


Keep up the great work.

Can’'t startup spark 2.0,cause by:

Caused by: java.util.MissingResourceException: Can’'t find bundle for base name i18n/spark_i18n, locale zh_CN

at java.util.ResourceBundle.throwMissingResourceException(Unknown Source)

at java.util.ResourceBundle.getBundleImpl(Unknown Source)

at java.util.ResourceBundle.getBundle(Unknown Source)

at org.jivesoftware.resource.Res.(

… 12 more

How can I just startup spark 2.0 in English?

Full I18N support??

Does auto reconnect feature enabled in release? Or i must do manual reconnect after connection is lost?

Online installation without JRE is 9.1Mb. ‘‘Online’’ means that i must be connected to internet and some components will be downloaded from jive site or it means only ‘‘without JRE’’ distribution?

The online installation killed my Spark. It’'s stopped with an error occurred:

java.lang.UnsupportedClassVersionError: org/jivesoftware/installer (Unsupported major.minor version 49.0)

It’'s a major problem when all of the users click on Yes to update to the new version and Spark will disappear.

Below is the error log.


java.lang.UnsupportedClassVersionError: org/jivesoftware/Installer (Unsupported major.minor version 49.0)

at java.lang.ClassLoader.defineClass0(Native Method)

at java.lang.ClassLoader.defineClass(Unknown Source)

at Source)

at Source)

at$100(Unknown Source)

at$ Source)

at Method)

at Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at com.install4j.runtime.installer.InstallerUtil.newUserInstance(Unknown Source)

at com.install4j.runtime.installer.InstallerUtil.instantiateClass(Unknown Source)

at com.install4j.runtime.installer.InstallerUtil.instantiateAction(Unknown Source)

at com.install4j.runtime.installer.Installer.doInstallation(Unknown Source)

at com.install4j.runtime.installer.Installer.install(Unknown Source)

at com.install4j.runtime.installer.frontend.screens.InstallationScreen$ wn Source)

System properties:™ 2 Runtime Environment, Standard Edition



sun.boot.library.path=c:\program files\java\j2re1.4.2_03\bin


java.vm.vendor=Sun Microsystems Inc.


path.separator=; HotSpot™ Client VM

sun.os.patch.level=Service Pack 2 Virtual Machine Specification




java.endorsed.dirs=c:\program files\java\j2re1.4.2_03\lib\endorsed



java.vm.specification.vendor=Sun Microsystems Inc.


exe4j.tempDir=C:\DOCUME1\TRITU1\LOCALS~1\Temp\e4j9E.tmp_dir1752 XP



java.library.path=c:\progra~1\spark\bin;.;C:\WINDOWS\system32;C:\WINDOWS;C:\WIND OWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\OpenVPN\bin Platform API Specification





user.home=C:\Documents and Settings\Tri Tu




java.class.path=C:\DOCUME1\TRITU1\LOCALS1\Temp\e4j9E.tmp_dir1752\i4jruntime.jar;C:\DOCUME1\TRITU1\LOCALS1\Temp\e4j9E.tmp_dir1752\user.jar;C:\DOCUME1\TRITU1\LOCALS~1\Temp\e4j9E.tmp_dir1752\; Tu


java.home=c:\program files\java\j2re1.4.2_03



java.specification.vendor=Sun Microsystems Inc. mode


java.ext.dirs=c:\program files\java\j2re1.4.2_03\lib\ext

sun.boot.class.path=c:\program files\java\j2re1.4.2_03\lib\rt.jar;c:\program files\java\j2re1.4.2_03\lib\i18n.jar;c:\program files\java\j2re1.4.2_03\lib\sunrsasign.jar;c:\program files\java\j2re1.4.2_03\lib\jsse.jar;c:\program files\java\j2re1.4.2_03\lib\jce.jar;c:\program files\java\j2re1.4.2_03\lib\charsets.jar;c:\program files\java\j2re1.4.2_03\classes

java.vendor=Sun Microsystems Inc.




sun.cpu.isalist=pentium i486 i386

The Release Version doesn’'t start for me either:

Exception in thread “AWT-EventQueue-0” java.lang.ExceptionInInitializerError

at org.jivesoftware.LoginDialog$LoginPanel.(

… 12 more

Simple copy file in spark.jar\i18n\ with name of your locale. Ex: or something like this.

Thanks, that did help

Reconnect Button does’'nt work with Spark 2.0.4 Linux

Exception in thread “AWT-EventQueue-0” java.lang.IllegalArgumentException: Empty command

at java.lang.Runtime.exec(Unknown Source)

at java.lang.Runtime.exec(Unknown Source)

at org.jivesoftware.MainWindow.closeConnectionAndInvoke(

at org.jivesoftware.MainWindow.access$200(

at org.jivesoftware.MainWindow$2.finished(

at org.jivesoftware.spark.util.SwingWorker$2$

at java.awt.event.InvocationEvent.dispatch(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at Source)


Is it an accident that most of the i18 languages are missing?

Is there somewhere I can get the some of the other languages?

Also every time I run the new client it pop’'s up a message saying that there is a new client available and the i need to shut down the client to install it.

Thanks for the new release, apart from the little problems it looks great.

This release still will not run on my AMD, crashing out after authentication, generating a Java error containing the following:

  1. An unexpected error has been detected by HotSpot Virtual Machine:

  1. EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x6d75c5cc, pid=200, tid=2388

  1. Java VM: Java HotSpot™ Client VM (1.5.0_08-b03 mixed mode, sharing)

  2. Problematic frame:

  3. V



For a while try to copy file for english locale as i wrote before.

I think that this files can be translated manually but when i try to change with CP1251 codepage, spark can’'t run with errors in log file.

I am having the same problem. The exact error message is “You need to shut down the client to install the latest version. Would you like to do that now?”

I have done the Spark automatic update through the Spark software. I have manually downloaded the full ~19MB offline install and installed it again that way. I have manually gone to Add or Remove Programs to uninstall and then reinstalled the full offline install. I still get the same exact error message.

Ditto on the problems everyone else here is seeing. But mine started a few days before the release version from the svn builds. See my other post on this for more info.

Hi linger,

I’'m making the fix to default back to english if no matching languages are found. This is filed as SPARK-342, and will be released on this upcoming Tuesday.



any word on the "“You need to shut down the client to install the latest version. Would you like to do that now?” error message?

Yes, make sure you are not running Spark before you install the latest version…

Autoupdate does not seem to be detecting the correct version. It continually prompts the user to update Spark then the Java runtime… This has occured on 3 different installations.