powered by Jive Software

Spark 2.9.2 search problem

spark does not search for people on the server. Unfortunately, there was

no such problem in older versions.

Hello!
I am using Spark 2.8.3 and nothing happens if I press the button.
The only solution is to use Ctrl + F.
Although @wroot can tell you what the problem might be.

It works for me. I only get such error when there is no such user on the server. Also, keep in mind that search is case sensitive. So if you have a user Mary Jane, and you search for jane. It will return this error. You have to search for Jane instead.

There is a ticket for this https://issues.igniterealtime.org/browse/SPARK-2048
And one for usernames with spaces, which also cannot be found https://issues.igniterealtime.org/browse/SPARK-2050

I used Spark 2.8.3, Spark 2.9.2 and Spark 2.9.3snapshot05/10/2020
No matter how hard I tried to find a person, I could not.
I wrote both ‘’ Hlevnoy Ilya ‘and’ Hlevnoy ‘and’ hlevnoy ’
I couldn’t even find “testuser” and “testuser2” which don’t have a first and last name.

I thought maybe search is disabled on the Openfire server, but no.


I haven’t tried all of them, it’s not a problem because of it.

There was no problem with the old versions guys. This problem appeared in version 2.9

ctrl + f only searches the current list, but to search the database we want.

You search window is missing checkboxes. Also, do you use AD or are your users local in the database? I am testing with local users (don’t have AD). Although there were reports that search with AD worked as well in early 2.9 versions, there was only problem that only usernames were returned in results.

image

The program works on a local network system, but the network structure is large. There are an average of 200-300 people in the network we use. Regardless of the username in Spark 2.8, when I called, I was listing and I could request the person to be added to my list with the right button. For example, even if “xxxyyy” was written “xx” in the search field, anyone who started with “xx” would come and now even 1 person does not come to the list, unfortunately. I couldn’t figure out what I tried.

[image]

search.service = deneme.local

The number of users is not that important. Do you import users from AD/LDAP?
Do your usernames has spaces, like “xxx yyy”? I mean usernames, not the actual names.

Usernames are “xxx.yyy” with periods between them. For example, his name is Ufuk Hamza, his username is “ufuk.hamza”.
"no signs

This doesn’t sound right. Search service should be in a form search.your_Openfire_domain.
In this case it seems that it is set as the name of your AD domain. As i have never used AD integration, i can’t say if this is normal, but i think it is not.

In Admin Console on the first page what is set as XMPP Domain Name? Maybe you can’t say it here. But if it is for example “chatserver.org”, then your search service should be search.chatserver.org.

Have tried with dots. Still works for me.

image

Well, i am using a slightly newer version. You can try it, but i don’t think it will change anything for you. https://bamboo.igniterealtime.org/browse/SPARK-NIGHTLY-1499/artifact/shared/Install4j-generated-media/
Probably need the with-jre version. Unless you install Java separately.

There was no problem with spark 2.8.3, my teacher, this problem occurred after 2.9. I uninstalled it and reverted to the old version. At this time, the user conversation screens do not turn off and remain on the screen. Somehow I will figure it out but how. Thanks

I will download spark_2_9_3-SNAPSHOT-with-jre.exe and try. I think nothing changes, but I will write to you tomorrow. Thanks. Good evening

I understand that it works in 2.8.3. But there were a lot of changes during these 3 years before 2.9 release. So we need to figure out why it is not working for you for us to be able to fix it. I can’t reproduce this so far.

As for your 2.8.3 not closing chat window is because of a bug that was in 2.9 at some point and now your Spark profile has files from 2.9 version. You need to exit Spark, go to C:\users\your_user\AppData\Roaming\Spark and delete plugins folder.

1 Like

Thank you guys, I found a lot of solutions here. At the same time, my English is not that good, I translate from Google, but we get along.

If these problems are fixed in 2.9, this version is great.