powered by Jive Software

SparkWeb for External Users

Hi,

I’m trying to set up sparkweb so that users not connected to the VPN can have access. I see that the link for sparkweb is in the openfire enterprise admin tool… but I’m not sure how to get it working for external users.

Any help would be great.

Hi kdingman,

I think we spoke on the phone about this issue and I just wanted to make sure everything was working. In order for sparkweb to be accessable to external users you need to allow ports 5222 and 9090 on your external firewall or router to forward to your openfire server. Once that is set up your users should be able to access sparkweb at http://externaladress:9090/plugins/enterprise/sparkweb/index.jsp

Hope this helps,

~Sean

Thanks for your help, both on the phone and here.

We actually still have not resolved the problem, as we’ve opened both ports on both of our proxy servers and the page is still not found when outside of the network. I’ve researched it thoroughly and still cannot make the page available to external users.

Hey Sean,

SparkWeb could be hosted by the web server included in Openfire or you can move it and host it in any other application server or web server of your choice. If you want to move it to your webserver of choice you will need to copy the folder plugins/enterprise/web/sparkweb to your websever. Port 9090 is the one used by the web server provided by Openfire so if you move SparkWeb to your webserver then you won’t need to open port 9090.

SparkWeb by default will connect to the server using port 5222 but you can also indicate SparkWeb to use HTTP or HTTPS to connect to the server.

Therefore, if you decide to move SparkWeb to your webserver (that uses port 80) and you indicate SparkWeb to use HTTP then you will only need to make sure that your firewall is letting you use port 80.

Regards,

– Gato

Hi kdingman,

Just out of curiousity. Have you gotten this working within the firewall? Can you log in and everything? If so are you using LDAP to authticate or are you using the accounts created on the Openfire server? The reason I am asking is because we are having difficulty even gettin this to work with the firewall.

Thanks,

DContinuum

Thanks for your help, everyone.

After moving /plugins/enterprise/web/sparkweb to our webserver, external users now see the sparkweb.swf page but cannot log in. Internally, most computers allow users to login via the sparkweb.swf page on our webserver. However, on some desktops, we’re experiencing problems logging in. We get a “not authorized” error, even though the same logon works on other desktops on the same network, in the same room even.

Any help would be great.

DContinuum,

Like I said above, we can log in internally…except for some computers. We use LDAP.

I believe I’ve indicated HTTP and opened the correct ports… without any luck. How does Sparkweb, when put on a different web address, know how to contact our Openfire server? Thx.

When you visit the sparkweb page and enter your login information, you enter the server name along with your username and password. Sparkweb takes that information and uses it to connect to your openfire server.

So what would be your recommendation for addressing why outside users cannot connect? Port 80 is open as Gato recommended… so I’m unsure of what to try next.

Is there any pattern to the failures? Specific browsers, OSs, or network configs?

While a few computers internally cannot connect, I’m more concerned with the users outside of the network that can not log in. No matter what ports I open or what I change in the index.html file (the one with all the javascript that runs the SWF), sparkweb never works for external users. I’ve really hit a brick wall with the issue and am just looking for any help at all. Thanks!

For more information, I’ve tried this on Firefox, IE 7, IE 6… we’re running Windows XP but I’ve also tried Vista. As far as ports and such… I’ve opened and closed ports on both of our proxy servers but to no avail.

Could you paste your jive_sparkweb_getConfig() function? There was a bug in the default config function for 3.4.4 that caused it to always use socket mode, even when https or http was requested.

<script type=“text/javascript”>

function jive_sparkweb_getConfig()

{

return {

server: spark.oursite.com,

connectionType: “http”,

autologin: “false”,

port: 5222,

policyFileURL: “xmlsocket://spark.oursite.com:80”

};

}

</script>


Not sure if that is right, any help is appreciated

You did the same thing I did

Need quotes around your string literals, like so:

function jive_sparkweb_getConfig()
{
return {
server: “spark.oursite.com”,
connectionType: “http”,
autologin: “false”,
port: 5222,
policyFileURL: “xmlsocket://spark.oursite.com:80”

};
}

I should really add some sort of diagnostic for failing to load the config properly… /me goes off to file a JIRA issue

Thanks for the tip… added the quotes and nothing changed.

Anything else that might be wrong?

ah, just noticed what you have the port set to. Make sure http binding is turned on in openfire, and set the port to the http binding port. 5222 is for socket connections.

Thanks. HTTP Binding is enabled… and I’ve now set the port to 8080. External users try to log in but receive a “Not Authorized” message.

<script type=“text/javascript”>

function jive_sparkweb_getConfig()

{

return {

server: “spark.oursite.com”,

connectionType: “http”,

autologin: “false”,

port: 8080,

policyFileURL: “xmlsocket://spark.oursite.com:80”

};

}

</script>


Still not luck. Any other ideas? Thank you!

Hi,

I’m still having a problem with getting Sparkweb to work externally. I’d really appreciate any other help…

It sounds like there may be some strange routing or DNS issues within your internal infrastructure. For your internal machines that cannot connect, have you tried entering the IP address of the openfire server as opposed to the dns name?

Regarding internal, if I change it to the IP address it still doesn’t authorize on certain PCs. That isn’t a big problem though…

I’m much more concerned with users not being able to connect when outside of the network, if you have any ideas concerning that. Thanks again for your help.