powered by Jive Software

User Summary List Empty at OF Admin

GENERAL INFORMATION:

Since update to OF 3.8.1 i’ve had problems with listing users @ OF admin interface, the list is completely empty, yet where it says “Total Users:” it shows the correct amount of users.

I’ve had no problems in OF 3.7.X and i saw everything. I can search the users one by one and they show up, but i can’t see the entire list.

This is an extremely important feature for me, as i am not managing thousands of users, so having a list is perfect.

TROUBLESHOOT INFO:

It seems to be some sort of issue with database. When i observe the “Warn.” logs of my OF server then every time i “refresh” or go the the "User Summary Page it adds another line to the “Warn.” log list.

The lines are simillar and they are, for example:

2013.03.19 16:39:46 org.jivesoftware.util.log.util.CommonsLogFactory - Unable to set status of connection 11 from ACTIVE to AVAILABLE because it’s state was NULL
2013.03.19 16:44:26 org.jivesoftware.util.log.util.CommonsLogFactory - Unable to set status of connection 14 from ACTIVE to AVAILABLE because it’s state was NULL
2013.03.19 16:45:14 org.jivesoftware.util.log.util.CommonsLogFactory - Unable to set status of connection 17 from ACTIVE to AVAILABLE because it’s state was NULL

This is all the information i’ve got, i hope someone has a solution to this as i am not competent enough to figure out where the problem exactly lies.

Any questions about this, feel free to ask and thanks in advance.

1 Like

I’m still struggling with the issue.

Can anyone else see if their OF 3.8.1 Server under Windows has the same problem?

What database / source of users are you using?

Thanks for responding, I’m using MySQL 5.6.10 and i didn’t have the same problem with OF 3.7.1

Everything is fine on both my servers, but i’m using the embedded database.

Very odd. Could this issue appear when, for example, a table or something from the database gets deleted?

Maybe somehow something from my database got removed during or after the update.

I am having the same issue. On 3.8.1 imbedded database I can see all users in user summary but I installed on a production server 3.8.2 with a MySql 5.6.11 and the user summary is empty. Please help I want to roll this out but need to make sure it is functing as expected.

I’m glad I’m not alone in this. I am still experiencing the issue with Openfire 3.8.2 on my server using MySQL database. (Settings described above). I was really hoping this gets fixed in 3.8.2, but so far no.

It seems to be something to do with the major OF update to 3.8.X from 3.7.X.

Until they can figure it out, you can use the “Search” function in admin interface, which is slow and annoying as hell to use, but it is the only option you got at the moment, also you can’t see users who have registered.

If any developers need more information, please feel free to ask, I’ll do my best of providing it. Also i have been trying to get this fixed by myself, but so far nothing works.

1 Like

Exact same thing here so obviously its a common issue. My setup is with openfire 3.8.2 using mysql 5.6.12 . Its working fine as stated by previous comments but would be nice to be able to see all the users. Thanks for all your hard work, other than this minor glitch it is an excellent product.

1 Like

Wonder if this can be related to OF-654. As al affected are on mysql 5.6.x. Or this is a separate issue.

I have the same issue.

I’m using OpenFire 3.8.2 hosted in a EC2 - Amazon Server (Linux) with MySQL 5.6.12 (RDS - Amazon).

All works fine but the user-summary.jsp is empty all the time.
I can get all users name using DBAccess OpenFire Plugin and using the “Search Users” field

I’ve heard that put MySQL on version 5.1.xx could solve the problem.
Anyone tried it before? Anyone found a solution to this issue?

Thanks

I’m not sure if setting the MySQL version to 5.1.XX helps, since i’ve been using MySQL 5.6.XX before and didn’t have the issue. So something is definently changed with Openfire 3.8.X which causes the problem to so many users.

So far, haven’t found a way to fix this problem, getting quite frustrating.

1 Like

Thanks for the reply.

So far I did not found any other problem with of, so i will keep using this version.

If I find something new about this subject I’ll come back here to write about.

o/

Just a bump for this - have there been any updates? I’m having the same issue on a fresh installation. I’m also experiencing very similar issues on the Server Manager > Statistics page, if any of you have that plugin.

OS: Windows Server 2008 R2 Standard SP1

Openfire: 3.8.2

MySQL: 5.6.13

No, i believe this is on their low priority of bugs list, IF they even know about the bug. Since if some users report it’s not working and some users say it’s working, like with any other software, the dev’s don’t consider it a bug or even test-worthy. It might get fixed after some years or when they experience the bug themselves i guess. Meanwhile you can try to find workarounds, i am just browsing the database table where the users are manually, annoying as hell, but the only way for me at the moment.

2 Likes

We don’t have any active openfire developers at the moment, only folks that hack at things as they need or have interest in. We need more committers!

I make Dejavu words mine. :confused:

is it simply that the mysql jdbc driver needs updating? It seems most of the users having issue are using mysql 5.6.x version… and people without issue are on older versions. 5.6.x is drastically different over the older 5.1.x that most “server” linux distros ship with… on windows servers of course users must manually install mysql, so they get the latest package.

i use mysql 5.1.x as my database on a openfire 3.8.2 server running on CentOS 6.x. all works as expected.

EDIT: I just looked, Openfire 3.8.2 is using MySQL JDBC Driver version 5.0.8 – the latest from the mysql site is 5.1.26 – perhaps someone experiencing this issue should try updating the driver and testing it out…

Message was edited by: Jason

It appears that you can update your mysql jdbc driver by replacing the one under the Openfire installation directory’s lib/ directory. It’s called “mysql.jar” right now… just back that up, download the latest from mysql’s site, and copy it into that lib/ directory (making sure to call it the same name - mysql.jar).

I have attached the lastest MySQL JDBC Driver for convinience… if you feel so inclinded to download your own… it’s available at:

http://dev.mysql.com/get/Downloads/Connector-J/mysql-connector-java-5.1.26.zip/f rom/http://cdn.mysql.com/

– Make sure you rename this download jar to “mysql.jar” before dropping it into your openfire_installation/lib/ directory
mysql-connector-java-5.1.26-bin.jar (855948 Bytes)

Thanks I was having the same problem and this fixed it.

Fabian Wilson | IT Specialist - Service Delivery

Kohl’s Department Stores, Inc | 10000 Rogers Run | San Antonio, TX 78251

210-688-3915 | fabian.wilson@kohls.com

On Thu, Sep 12, 2013 at 3:26 PM, SnakeDoc <communityadmin@igniterealtime.org